aboutsummaryrefslogtreecommitdiffstats
path: root/community/tokei/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/tokei/APKBUILD')
-rw-r--r--community/tokei/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/tokei/APKBUILD b/community/tokei/APKBUILD
index fa0dca6bbf6..59622af5c53 100644
--- a/community/tokei/APKBUILD
+++ b/community/tokei/APKBUILD
@@ -2,18 +2,20 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=tokei
pkgver=12.1.2
-pkgrel=0
+pkgrel=4
pkgdesc="A blazingly fast CLOC (Count Lines Of Code) program"
url="https://github.com/XAMPPRocky/tokei"
-arch="all !s390x !mips !mips64 !riscv64" # limited by cargo
+arch="all !s390x !riscv64" # limited by cargo
license="MIT AND Apache-2.0"
-makedepends="rust cargo"
+makedepends="rust cargo cargo-auditable"
source="$pkgname-$pkgver.tar.gz::https://github.com/XAMPPRocky/tokei/archive/v$pkgver.tar.gz
minimize-size.patch
+ open64.patch
"
+
build() {
- cargo build --release --locked --features all
+ cargo auditable build --release --locked --features all
}
check() {
@@ -24,5 +26,8 @@ package() {
install -Dm755 target/release/tokei "$pkgdir"/usr/bin/tokei
}
-sha512sums="b8474cb3cad8cab8cb9c24b44a9b7bdaa436fde4e56ca25a8c6d9cbe342b27acf8041cda15da5e74b4fed5291b3eacd5b298f569e0c8041e9146f89847fe47ce tokei-12.1.2.tar.gz
-896902676bbd85acbcc2ee62ab1f1ff5c55be986b9e8ba2ebd976a5be0df274184aa8e3354c89b1bb628cd70f14f9d5d5977701f09e3a406277d7c11d5b0426e minimize-size.patch"
+sha512sums="
+b8474cb3cad8cab8cb9c24b44a9b7bdaa436fde4e56ca25a8c6d9cbe342b27acf8041cda15da5e74b4fed5291b3eacd5b298f569e0c8041e9146f89847fe47ce tokei-12.1.2.tar.gz
+896902676bbd85acbcc2ee62ab1f1ff5c55be986b9e8ba2ebd976a5be0df274184aa8e3354c89b1bb628cd70f14f9d5d5977701f09e3a406277d7c11d5b0426e minimize-size.patch
+e417d70c861130c087fa94dccd63080207a021f74b8e1d43cd26e830537162b9b8f3bb36790a6c21cee59e757fae0ec7448cd7d6aa150e070b92d36d5cdb5587 open64.patch
+"