aboutsummaryrefslogtreecommitdiffstats
path: root/community/torsocks/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/torsocks/APKBUILD')
-rw-r--r--community/torsocks/APKBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/community/torsocks/APKBUILD b/community/torsocks/APKBUILD
index 39e09eab2bf..af0ca0c9c73 100644
--- a/community/torsocks/APKBUILD
+++ b/community/torsocks/APKBUILD
@@ -1,20 +1,19 @@
-# Maintainer: Christian Kampka <christian@kampka.net>
+# Contributor: Christian Kampka <christian@kampka.net>
+# Maintainer: omni <omni+alpine@hack.org>
pkgname=torsocks
-pkgver=2.3.0
+pkgver=2.4.0
pkgrel=0
pkgdesc="Wrapper to safely torify applications"
-url="https://gitweb.torproject.org/torsocks.git"
+url="https://gitlab.torproject.org/tpo/core/torsocks"
arch="all"
license="GPL-2.0"
-depends="tor"
makedepends="$depends_dev autoconf automake libtool"
subpackages="$pkgname-doc"
-source="https://people.torproject.org/~dgoulet/${pkgname}/${pkgname}-${pkgver}.tar.xz"
-
-builddir="${srcdir}/${pkgname}-${pkgver}"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.torproject.org/tpo/core/torsocks/-/archive/v$pkgver/torsocks-v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
build() {
- cd "$builddir"
+ ./autogen.sh
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,13 +25,13 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="4888caaffdcfebf3673e14f3491eae6aa84ca0a4a2a812ba7bdac2abb471307e89a3c5cffe7691fb6f190c7bd9ea455ee9a223d909a39152be8524f590be2031 torsocks-2.3.0.tar.xz"
+sha512sums="
+7d625ce3a4600f87b86ae9ac79dfd206e7709cb0bafe0b7afcf33a6f1825f968cc63ad3e23c584582b244647bdeafbfdbfc54f7c81e521b0a3d278a1483ce86e torsocks-2.4.0.tar.gz
+"