aboutsummaryrefslogtreecommitdiffstats
path: root/community/totem/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/totem/APKBUILD')
-rw-r--r--community/totem/APKBUILD48
1 files changed, 36 insertions, 12 deletions
diff --git a/community/totem/APKBUILD b/community/totem/APKBUILD
index 4ce7cb36f07..9dd4f434147 100644
--- a/community/totem/APKBUILD
+++ b/community/totem/APKBUILD
@@ -1,32 +1,56 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=totem
-pkgver=3.38.0
-pkgrel=0
+pkgver=43.0
+pkgrel=3
pkgdesc="Movie player for the GNOME desktop"
url="https://wiki.gnome.org/Apps/Videos"
-arch="all !s390x !mips64" # grilo-plugins missing
+arch="all !s390x !riscv64" # grilo-plugins missing
license="GPL-2.0-or-later"
-depends="gsettings-desktop-schemas gst-plugins-good grilo-plugins"
-makedepends="meson glib-dev gtk+3.0-dev gstreamer-dev libpeas-dev totem-pl-parser-dev
- gobject-introspection-dev clutter-gtk-dev py3-gobject3-dev grilo-dev
- gnome-desktop-dev vala gsettings-desktop-schemas-dev gst-plugins-base-dev
- libxml2-dev gstreamer-tools clutter-gst-dev itstool"
+depends="
+ grilo-plugins
+ gsettings-desktop-schemas
+ gst-libav
+ gst-plugins-good
+ gst-plugins-good-gtk
+ "
+makedepends="
+ clutter-gtk-dev
+ glib-dev
+ gnome-desktop-dev
+ gobject-introspection-dev
+ grilo-dev
+ gsettings-desktop-schemas-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gstreamer-tools
+ gtk+3.0-dev
+ itstool
+ libhandy1-dev
+ libpeas-dev
+ libxml2-dev
+ meson
+ py3-gobject3-dev
+ totem-pl-parser-dev
+ vala
+ "
checkdepends="xvfb-run desktop-file-utils appstream-glib"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/totem/${pkgver%.*}/totem-$pkgver.tar.xz"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="231aca873bb53f23f81a7981177761d0bf7768baa845309b0dc0821db58377d692cf7e8a65135090dac14e856aa3e1dc0c1f11c55a7b25d694822019bfa9eecf totem-3.38.0.tar.xz"
+sha512sums="
+b35d32ebadf4b9900ab234f07f8a7128edbc15593e1447c22f3c7a653fcbd4a2df9d45484e2decce5dd5ab67849fca1003a1ded338a0af0930b6560ee4f764ae totem-43.0.tar.xz
+"