aboutsummaryrefslogtreecommitdiffstats
path: root/community/tpm2-tss
diff options
context:
space:
mode:
Diffstat (limited to 'community/tpm2-tss')
-rw-r--r--community/tpm2-tss/0001-FAPI-fix-bug-of-bad-type-casting.patch36
-rw-r--r--community/tpm2-tss/0001-configure-Check-system-with-busybox.patch74
-rw-r--r--community/tpm2-tss/0001-tests-enable-tcti-pcap-tests-on-big-endian-platforms.patch143
-rw-r--r--community/tpm2-tss/APKBUILD138
-rw-r--r--community/tpm2-tss/dl_test_fix.patch30
-rw-r--r--community/tpm2-tss/musl-32bit-stat-workaround.patch31
-rw-r--r--community/tpm2-tss/pcap_test_fix.patch30
7 files changed, 87 insertions, 395 deletions
diff --git a/community/tpm2-tss/0001-FAPI-fix-bug-of-bad-type-casting.patch b/community/tpm2-tss/0001-FAPI-fix-bug-of-bad-type-casting.patch
deleted file mode 100644
index 869f37ff66a..00000000000
--- a/community/tpm2-tss/0001-FAPI-fix-bug-of-bad-type-casting.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From fa57dd7b1174bf21c12d8d37535404702044f0a3 Mon Sep 17 00:00:00 2001
-From: Andreas Fuchs <andreas.fuchs@sit.fraunhofer.de>
-Date: Fri, 16 Jul 2021 15:35:23 +0200
-Subject: [PATCH 1/1] FAPI: fix bug of bad type casting
-
-Signed-off-by: Andreas Fuchs <andreas.fuchs@sit.fraunhofer.de>
----
- src/tss2-fapi/ifapi_get_intl_cert.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/tss2-fapi/ifapi_get_intl_cert.c b/src/tss2-fapi/ifapi_get_intl_cert.c
-index db628293..b66e0650 100644
---- a/src/tss2-fapi/ifapi_get_intl_cert.c
-+++ b/src/tss2-fapi/ifapi_get_intl_cert.c
-@@ -195,7 +195,8 @@ base64_encode(const unsigned char* buffer)
- static char *
- base64_decode(unsigned char* buffer, size_t len, size_t *new_len)
- {
-- size_t i, unescape_len = 0, r;
-+ size_t i, r;
-+ int unescape_len = 0;
- char *binary_data = NULL, *unescaped_string = NULL;
-
- LOG_INFO("Decoding the base64 encoded cert into binary form");
-@@ -218,7 +219,7 @@ base64_decode(unsigned char* buffer, size_t len, size_t *new_len)
- if (curl) {
- /* Convert URL encoded string to a "plain string" */
- char *output = curl_easy_unescape(curl, (char *)buffer,
-- len, (int *)&unescape_len);
-+ len, &unescape_len);
- if (output) {
- unescaped_string = strdup(output);
- curl_free(output);
---
-2.33.0
-
diff --git a/community/tpm2-tss/0001-configure-Check-system-with-busybox.patch b/community/tpm2-tss/0001-configure-Check-system-with-busybox.patch
deleted file mode 100644
index 4099c2ff018..00000000000
--- a/community/tpm2-tss/0001-configure-Check-system-with-busybox.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 7fde604383c62fc764a1e060dff48fc06f79860b Mon Sep 17 00:00:00 2001
-From: Juergen Repp <juergen.repp@sit.fraunhofer.de>
-Date: Wed, 1 Dec 2021 12:54:03 +0100
-Subject: [PATCH] configure: Check system with busybox.
-
-Busybox does not support useradd and groupadd. If useradd and groupadd are
-not available adduser and addgroup will be used during FAPI installation.
-
-Signed-off-by: Juergen Repp <juergen.repp@sit.fraunhofer.de>
----
- Makefile.am | 17 +++++++++++++++--
- configure.ac | 16 +++++++++-------
- 2 files changed, 24 insertions(+), 9 deletions(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index 521dcee9..049be206 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -636,8 +636,21 @@ define make_parent_dir
- endef
-
- define make_tss_user_and_group
-- (id -g tss 2>/dev/null || groupadd -r tss) && \
-- (id -u tss 2>/dev/null || useradd -r -g tss tss)
-+ if type -p groupadd > /dev/null; then \
-+ id -g tss 2>/dev/null || groupadd --system tss; \
-+ else \
-+ id -g tss 2>/dev/null || \
-+ addgroup --system tss; \
-+ fi && \
-+ if type -p useradd > /dev/null; then \
-+ id -u tss 2>/dev/null || \
-+ useradd --system --home-dir / --shell `type -p nologin` \
-+ --no-create-home -g tss tss; \
-+ else \
-+ id -u tss 2>/dev/null || \
-+ adduser --system --home / --shell `type -p nologin` \
-+ --no-create-home --ingroup tss tss; \
-+ fi
- endef
-
- define make_tss_dir
-diff --git a/configure.ac b/configure.ac
-index 1b7ce126..5a8c5f74 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -487,15 +487,17 @@ AC_CHECK_PROG(systemd_sysusers, systemd-sysusers, yes)
- AM_CONDITIONAL(SYSD_SYSUSERS, test "x$systemd_sysusers" = "xyes")
- AC_CHECK_PROG(systemd_tmpfiles, systemd-tmpfiles, yes)
- AM_CONDITIONAL(SYSD_TMPFILES, test "x$systemd_tmpfiles" = "xyes")
-+
- # Check all tools used by make install
- AS_IF([test "$HOSTOS" = "Linux"],
-- [ERROR_IF_NO_PROG([groupadd])
-- ERROR_IF_NO_PROG([useradd])
-- ERROR_IF_NO_PROG([id])
-- ERROR_IF_NO_PROG([chown])
-- ERROR_IF_NO_PROG([chmod])
-- ERROR_IF_NO_PROG([mkdir])
-- ERROR_IF_NO_PROG([setfacl])])
-+ [ AC_CHECK_PROG(useradd, useradd, yes)
-+ AC_CHECK_PROG(groupadd, groupadd, yes)
-+ AC_CHECK_PROG(adduser, adduser, yes)
-+ AC_CHECK_PROG(addgroup, addgroup, yes)
-+ AS_IF([test "x$addgroup" != "xyes" && test "x$groupadd" != "xyes" ],
-+ [AC_MSG_ERROR([addgroup or groupadd are needed.])])
-+ AS_IF([test "x$adduser" != "xyes" && test "x$useradd" != "xyes" ],
-+ [AC_MSG_ERROR([adduser or useradd are needed.])])])
-
- AC_SUBST([PATH])
-
---
-2.34.1
-
diff --git a/community/tpm2-tss/0001-tests-enable-tcti-pcap-tests-on-big-endian-platforms.patch b/community/tpm2-tss/0001-tests-enable-tcti-pcap-tests-on-big-endian-platforms.patch
deleted file mode 100644
index ed7c611353f..00000000000
--- a/community/tpm2-tss/0001-tests-enable-tcti-pcap-tests-on-big-endian-platforms.patch
+++ /dev/null
@@ -1,143 +0,0 @@
-From f36283e61136e78bf4999dc63dc3363c6c7ecfb1 Mon Sep 17 00:00:00 2001
-From: Johannes Holland <johannes.holland@infineon.com>
-Date: Fri, 16 Jul 2021 20:29:28 +0200
-Subject: [PATCH] tests: enable tcti-pcap tests on big endian platforms
-
-Signed-off-by: Johannes Holland <johannes.holland@infineon.com>
----
- test/unit/tcti-pcap.c | 62 +++++++++++++++++++++----------------------
- 1 file changed, 31 insertions(+), 31 deletions(-)
-
-diff --git a/test/unit/tcti-pcap.c b/test/unit/tcti-pcap.c
-index 06b6a56b..c540de77 100644
---- a/test/unit/tcti-pcap.c
-+++ b/test/unit/tcti-pcap.c
-@@ -16,6 +16,7 @@
- #include <string.h>
- #include <time.h>
- #include <sys/stat.h>
-+#include <netinet/in.h>
-
- #include <setjmp.h>
- #include <cmocka.h>
-@@ -26,6 +27,14 @@
- #include "tss2-tcti/tcti-common.h"
- #include "tss2-tcti/tcti-pcap.h"
-
-+#if (__BYTE_ORDER__ == __ORDER_BIG_ENDIAN__)
-+#define _LE32TOH(a,b,c,d) d,c,b,a
-+#define _LE16TOH(a,b) b,a
-+#else
-+#define _LE32TOH(a,b,c,d) a,b,c,d
-+#define _LE16TOH(a,b) a,b
-+#endif
-+
- #define TCTI_STUB_CONF "stub"
- #define TCTI_PCAP_ENV_VAR "pcap_env_var"
- #define TCTI_PCAP_FILE "pcap_file"
-@@ -43,34 +52,34 @@
- #define TCTI_PCAP_HOST_PORT_BYTES 0xcd, 0xef
- #define TCTI_PCAP_TIMESTAMP_SEC ((uint64_t) 0x0001020304050607 / 1000000)
- #define TCTI_PCAP_TIMESTAMP_NSEC (((uint64_t) 0x0001020304050607 % 1000000) * 1000)
--#define TCTI_PCAP_TIMESTAMP_BYTES 0x03, 0x02, 0x01, 0x00, 0x07, 0x06, 0x05, 0x04
-+#define TCTI_PCAP_TIMESTAMP_BYTES _LE32TOH(0x03, 0x02, 0x01, 0x00), _LE32TOH(0x07, 0x06, 0x05, 0x04)
-
- static const uint8_t pcap_header[] = {
- /* section header block */
-- 0x0a, 0x0d, 0x0d, 0x0a,
-- 0x1c, 0x00, 0x00, 0x00,
-- 0x4d, 0x3c, 0x2b, 0x1a,
-- 0x01, 0x00,
-+ _LE32TOH(0x0a, 0x0d, 0x0d, 0x0a),
-+ _LE32TOH(0x1c, 0x00, 0x00, 0x00),
-+ _LE32TOH(0x4d, 0x3c, 0x2b, 0x1a),
-+ _LE16TOH(0x01, 0x00),
- 0x00, 0x00,
- 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff,
-- 0x1c, 0x00, 0x00, 0x00,
-+ _LE32TOH(0x1c, 0x00, 0x00, 0x00),
- /* interface description block */
-- 0x01, 0x00, 0x00, 0x00,
-- 0x14, 0x00, 0x00, 0x00,
-- 0xE4, 0x00,
-+ _LE32TOH(0x01, 0x00, 0x00, 0x00),
-+ _LE32TOH(0x14, 0x00, 0x00, 0x00),
-+ _LE16TOH(0xE4, 0x00),
- 0x00, 0x00,
- 0x00, 0x00, 0x00, 0x00,
-- 0x14, 0x00, 0x00, 0x00
-+ _LE32TOH(0x14, 0x00, 0x00, 0x00)
- };
-
- static uint8_t pcap_rx_epb_data[] = {
- /* enhanced packet block header */
-- 0x06, 0x00, 0x00, 0x00,
-- 0x4c, 0x00, 0x00, 0x00,
-+ _LE32TOH(0x06, 0x00, 0x00, 0x00),
-+ _LE32TOH(0x4c, 0x00, 0x00, 0x00),
- 0x00, 0x00, 0x00, 0x00,
- TCTI_PCAP_TIMESTAMP_BYTES,
-- 0x2b, 0x00, 0x00, 0x00,
-- 0x2b, 0x00, 0x00, 0x00,
-+ _LE32TOH(0x2b, 0x00, 0x00, 0x00),
-+ _LE32TOH(0x2b, 0x00, 0x00, 0x00),
- /* ipv4 header */
- 0x45,
- 0x00,
-@@ -96,17 +105,17 @@ static uint8_t pcap_rx_epb_data[] = {
- /* epb padding */
- 0x00,
- /* epb footer */
-- 0x4c, 0x00, 0x00, 0x00
-+ _LE32TOH(0x4c, 0x00, 0x00, 0x00)
- };
-
- static uint8_t pcap_tx_epb_data[] = {
- /* enhanced packet block header */
-- 0x06, 0x00, 0x00, 0x00,
-- 0x4c, 0x00, 0x00, 0x00,
-+ _LE32TOH(0x06, 0x00, 0x00, 0x00),
-+ _LE32TOH(0x4c, 0x00, 0x00, 0x00),
- 0x00, 0x00, 0x00, 0x00,
- TCTI_PCAP_TIMESTAMP_BYTES,
-- 0x2b, 0x00, 0x00, 0x00,
-- 0x2b, 0x00, 0x00, 0x00,
-+ _LE32TOH(0x2b, 0x00, 0x00, 0x00),
-+ _LE32TOH(0x2b, 0x00, 0x00, 0x00),
- /* ipv4 header */
- 0x45,
- 0x00,
-@@ -132,7 +141,7 @@ static uint8_t pcap_tx_epb_data[] = {
- /* epb padding */
- 0x00,
- /* epb footer */
-- 0x4c, 0x00, 0x00, 0x00
-+ _LE32TOH(0x4c, 0x00, 0x00, 0x00)
- };
-
- typedef struct {
-@@ -367,19 +376,10 @@ update_tcp_seq (void* data, uint32_t size)
- uint32_t seq_no;
-
- seq_no = *((uint32_t*) (data + offset));
-- /* from big endian to little endian */
-- seq_no = ((seq_no << 24) & 0xff000000) | /* byte 0 to byte 3 */
-- ((seq_no << 8) & 0x00ff0000) | /* byte 1 to byte 2 */
-- ((seq_no >> 8) & 0x0000ff00) | /* byte 2 to byte 1 */
-- ((seq_no >> 24) & 0x000000ff); /* byte 3 to byte 0 */
-
-+ seq_no = ntohl (seq_no);
- seq_no += size;
--
-- /* from little endian to big endian */
-- seq_no = ((seq_no << 24) & 0xff000000) | /* byte 0 to byte 3 */
-- ((seq_no << 8) & 0x00ff0000) | /* byte 1 to byte 2 */
-- ((seq_no >> 8) & 0x0000ff00) | /* byte 2 to byte 1 */
-- ((seq_no >> 24) & 0x000000ff); /* byte 3 to byte 0 */
-+ seq_no = htonl (seq_no);
-
- *((uint32_t*) (data + offset)) = seq_no;
- }
---
-2.33.0
-
diff --git a/community/tpm2-tss/APKBUILD b/community/tpm2-tss/APKBUILD
index 2738da3e087..1bcdb21fede 100644
--- a/community/tpm2-tss/APKBUILD
+++ b/community/tpm2-tss/APKBUILD
@@ -2,17 +2,23 @@
# Contributor: Alexander Sack <asac@pantacor.com>
# Maintainer: Alexander Sack <asac@pantacor.com>
pkgname=tpm2-tss
-pkgver=3.1.0
-pkgrel=0
+pkgver=4.0.1
+pkgrel=2
pkgdesc="TPM 2.0 TSS"
url="https://github.com/tpm2-software/tpm2-tss/"
pkgusers="tss"
pkggroups="tss"
arch="all"
license="BSD-2-Clause"
-makedepends="automake autoconf libtool openssl1.1-compat-dev doxygen perl
- linux-headers cmocka-dev autoconf-archive
- json-c-dev curl-dev acl"
+makedepends="
+ cmocka-dev
+ curl-dev
+ json-c-dev
+ linux-headers
+ openssl-dev>3
+ perl
+ util-linux-dev
+ "
_depends_fapi="acl"
subpackages="
$pkgname-doc
@@ -24,27 +30,31 @@ subpackages="
$pkgname-tcti-swtpm
$pkgname-tcti-cmd
$pkgname-tcti-pcap
+ $pkgname-tcti-spi-helper:spi_helper
+ $pkgname-policy
$pkgname-rc
$pkgname-tctildr
$pkgname-fapi
$pkgname-static
$pkgname-dev
"
-install="tpm2-tss-fapi.pre-install tpm2-tss-fapi.pre-upgrade tpm2-tss-fapi.post-install tpm2-tss-fapi.pre-upgrade"
+install="tpm2-tss-fapi.pre-install tpm2-tss-fapi.pre-upgrade tpm2-tss-fapi.post-install tpm2-tss-fapi.post-upgrade"
source="
- $pkgname-$pkgver.tar.gz::https://github.com/tpm2-software/tpm2-tss/archive/$pkgver.tar.gz
-
- 0001-FAPI-fix-bug-of-bad-type-casting.patch
- pcap_test_fix.patch
- 0001-tests-enable-tcti-pcap-tests-on-big-endian-platforms.patch
- dl_test_fix.patch
- 0001-configure-Check-system-with-busybox.patch
- musl-32bit-stat-workaround.patch
-"
+ https://github.com/tpm2-software/tpm2-tss/releases/download/$pkgver/tpm2-tss-$pkgver.tar.gz
+ "
+# fhs: /var/run/tpm2-tss/eventlog created in package()
+options="!fhs"
+
+case "$CARCH" in
+s390x)
+ # https://github.com/tpm2-software/tpm2-tss/issues/2531
+ options="$options !check"
+ ;;
+esac
prepare() {
- default_prepare
- ./bootstrap
+ default_prepare
+ update_config_sub
}
build() {
@@ -54,7 +64,6 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --without-udevrulesdir \
--with-tctidefaultmodule=device \
--with-tctidefaultconfig=/dev/tpmrm0 \
--with-crypto=ossl \
@@ -63,101 +72,128 @@ build() {
}
check() {
- make check
+ make check || {
+ cat ./test-suite.log
+ exit 1
+ }
}
package() {
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/etc/tmpfiles.d
rm -rf "$pkgdir"/etc/sysusers.d
+
+ mkdir -p "$pkgdir"/var/run/tpm2-tss/eventlog/
}
mu() {
pkgdesc="TPM 2.0 Marshaling libraries"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-mu.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-mu.so \
+ usr/lib/libtss2-mu.so.*
}
sys() {
pkgdesc="TPM 2.0 System API libraries"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-sys.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-sys.so \
+ usr/lib/libtss2-sys.so.*
}
esys() {
pkgdesc="TPM 2.0 Enhanced System API libraries"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-esys.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-esys.so \
+ usr/lib/libtss2-esys.so.*
}
device() {
pkgdesc="TPM 2.0 Device TCTI"
provides="libtss2-tcti"
provider_priority="100"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-tcti-device.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-tcti-device.so \
+ usr/lib/libtss2-tcti-device.so.*
}
mssim() {
pkgdesc="TPM 2.0 Simulator TCTI"
provides="libtss2-tcti"
provider_priority="10"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-tcti-mssim.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-tcti-mssim.so \
+ usr/lib/libtss2-tcti-mssim.so.*
}
rc() {
pkgdesc="TPM 2.0 RC libraries"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-rc.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-rc.so \
+ usr/lib/libtss2-rc.so.*
}
tctildr() {
pkgdesc="TPM 2.0 TCTI loader libraries"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-tctildr.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-tctildr.so \
+ usr/lib/libtss2-tctildr.so.*
}
fapi() {
depends="$_depends_fapi"
pkgdesc="TPM 2.0 FAPI libraries"
- mkdir -p "$subpkgdir"/usr/lib "$subpkgdir"/etc/tpm2-tss "$subpkgdir"/var/lib
- mv "$pkgdir"/usr/lib/libtss2-fapi.so.* "$subpkgdir"/usr/lib
- mv "$pkgdir"/etc/tpm2-tss/fapi-config.json "$subpkgdir"/etc/tpm2-tss
- mv "$pkgdir"/etc/tpm2-tss/fapi-profiles "$subpkgdir"/etc/tpm2-tss
- mv "$pkgdir"/var/lib/tpm2-tss "$subpkgdir"/var/lib
+
+ amove usr/lib/libtss2-fapi.so \
+ usr/lib/libtss2-fapi.so.* \
+ etc/tpm2-tss/fapi-config.json \
+ etc/tpm2-tss/fapi-profiles
+
+ mkdir -p "$subpkgdir"/var/lib/tpm2-tss/system/keystore/
}
swtpm() {
pkgdesc="TPM 2.0 SWTPM TCTI"
provides="libtss2-tcti"
provider_priority="10"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-tcti-swtpm.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-tcti-swtpm.so \
+ usr/lib/libtss2-tcti-swtpm.so.*
}
cmd() {
pkgdesc="TPM 2.0 CMD TCTI"
provides="libtss2-tcti"
provider_priority="10"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-tcti-cmd.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-tcti-cmd.so \
+ usr/lib/libtss2-tcti-cmd.so.*
}
pcap() {
pkgdesc="TPM 2.0 PCAP TCTI"
provides="libtss2-tcti"
provider_priority="10"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libtss2-tcti-pcap.so.* "$subpkgdir"/usr/lib
+
+ amove usr/lib/libtss2-tcti-pcap.so \
+ usr/lib/libtss2-tcti-pcap.so.*
+}
+
+spi_helper() {
+ pkgdesc="TPM 2.0 spi helper TCTI"
+ provides="libtss2-tcti"
+ provider_priority="10"
+
+ amove usr/lib/libtss2-tcti-spi-helper.so \
+ usr/lib/libtss2-tcti-spi-helper.so.*
+}
+
+policy() {
+ pkgdesc="TPM 2.0 policy library"
+
+ amove usr/lib/libtss2-policy.so \
+ usr/lib/libtss2-policy.so.*
}
sha512sums="
-d8a5079040415c1eb7ceb0d1d3c6a55b28526d6f6a156f9eea0814ef67b2cfc64ac8c157591dd77d24bbf2b0531573d66e192b0f24903e7ee70f5ef695ff2bbe tpm2-tss-3.1.0.tar.gz
-c11e3f6092b6984ab30d22bde9e667323e4ca51fa87476a93f1d52938e0f8c238a8cffe7e02d13eb59f0c39ee65da972e852864845e474f9f2d2f659a742ca52 0001-FAPI-fix-bug-of-bad-type-casting.patch
-1beec50db7e91361e4b06ee76bbb70fafaea0e532b1e3fbe27c6e0f36063f001f87c589eb93b43aeedce50e7d9d99068fdf32a8f82de81881408d3214ff60ba9 pcap_test_fix.patch
-f3af1703a6797e7998eed7e6dd8c538095acc0cd8b7dcf4c923f38d4257cba45959ffd03e0a797d7a2e0e004e1812fdb36922cfd4e5c58007af15f0383e45080 0001-tests-enable-tcti-pcap-tests-on-big-endian-platforms.patch
-a6b94c682d642f2337b53e3354e27d8492fa69c7f060cef833bd6c716c0dbafa4e59ffdaa64c109f09b7796d59e3c42cddadead320e9a6305ce03afeb1ef8471 dl_test_fix.patch
-8beb205681abee0832dd9bd02ab0d637146112649a6031a65df4ded02494381d91666cca67379000d316ef61a072d9db1e894f4fc5eb38fcb8f26ded9ac7b4f6 0001-configure-Check-system-with-busybox.patch
-abdfb1100e8f26bd745e083c12c6cef9d0e7c6d62adb2d97c24b55846849a1ca2a53f7e1fd5819668301513705e6d4c7342bc00ede4d258fbae617fbeaf65e3e musl-32bit-stat-workaround.patch
+ed6ddc52cb0e8c1082a4bb001e1225eb9905fd2380da88db5fd69ff5b5d9d43a93eb67b634e49d53eb5d586832da3aef2c4c7e5f18d51bb730481f8913319d7d tpm2-tss-4.0.1.tar.gz
"
diff --git a/community/tpm2-tss/dl_test_fix.patch b/community/tpm2-tss/dl_test_fix.patch
deleted file mode 100644
index e2820f1d2a0..00000000000
--- a/community/tpm2-tss/dl_test_fix.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/Makefile-test.am b/Makefile-test.am
-index d7347148..ab2d1425 100644
---- a/Makefile-test.am
-+++ b/Makefile-test.am
-@@ -475,7 +475,7 @@ test_unit_tctildr_dl_CFLAGS = $(CMOCKA_CFLAGS) $(TESTS_CFLAGS) \
- -UESYS_TCTI_DEFAULT_MODULE -UESYS_TCTI_DEFAUT_CONFIG
- test_unit_tctildr_dl_LDADD = $(CMOCKA_LIBS) $(TESTS_LDADD) $(LIBADD_DL)
- test_unit_tctildr_dl_LDFLAGS = -Wl,--wrap=dlopen,--wrap=dlclose,--wrap=dlsym \
-- -Wl,--wrap=tcti_from_init,--wrap=tcti_from_info
-+ -Wl,--wrap=tcti_from_init,--wrap=tcti_from_info,--wrap=__dlsym_time64
- test_unit_tctildr_dl_SOURCES = test/unit/tctildr-dl.c \
- src/tss2-tcti/tctildr-dl.c
-
-diff --git a/test/unit/tctildr-dl.c b/test/unit/tctildr-dl.c
-index 873a4531..4279baee 100644
---- a/test/unit/tctildr-dl.c
-+++ b/test/unit/tctildr-dl.c
-@@ -55,6 +55,12 @@ __wrap_dlsym(void *handle, const char *symbol)
- return mock_type(void *);
- }
-
-+void *
-+__wrap___dlsym_time64(void *handle, const char *symbol)
-+{
-+ return __wrap_dlsym(handle, symbol);
-+}
-+
- TSS2_TCTI_INFO *
- __wrap_Tss2_Tcti_Fake_Info(void)
- {
diff --git a/community/tpm2-tss/musl-32bit-stat-workaround.patch b/community/tpm2-tss/musl-32bit-stat-workaround.patch
deleted file mode 100644
index 687d909442e..00000000000
--- a/community/tpm2-tss/musl-32bit-stat-workaround.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/Makefile-test.am b/Makefile-test.am
-index 020b6680..135195ee 100644
---- a/Makefile-test.am
-+++ b/Makefile-test.am
-@@ -648,7 +648,8 @@ test_unit_fapi_io_LDFLAGS = $(TESTS_LDFLAGS) $(JSONC_LIBS) $(CURL_LIBS) \
- -Wl,--wrap=write \
- -Wl,--wrap=fileno \
- -Wl,--wrap=fclose \
-- -Wl,--wrap=stat
-+ -Wl,--wrap=stat \
-+ -Wl,--wrap=__stat_time64
- test_unit_fapi_io_SOURCES = test/unit/fapi-io.c \
- src/tss2-fapi/ifapi_json_deserialize.c \
- src/tss2-fapi/ifapi_json_serialize.c \
-diff --git a/test/unit/fapi-io.c b/test/unit/fapi-io.c
-index 41600ca9..08936d7e 100644
---- a/test/unit/fapi-io.c
-+++ b/test/unit/fapi-io.c
-@@ -57,6 +57,12 @@ int
- return 0;
- }
-
-+int
-+ __wrap___stat_time64(const char *pathname, struct stat *statbuf, ...)
-+{
-+ return __wrap_stat(pathname, statbuf);
-+}
-+
- FILE *
- __real_fopen(const char *pathname, const char* mode, ...);
- FILE *
diff --git a/community/tpm2-tss/pcap_test_fix.patch b/community/tpm2-tss/pcap_test_fix.patch
deleted file mode 100644
index 67f91242a68..00000000000
--- a/community/tpm2-tss/pcap_test_fix.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/Makefile-test.am b/Makefile-test.am
-index c4fb7803..b7844672 100644
---- a/Makefile-test.am
-+++ b/Makefile-test.am
-@@ -447,7 +447,8 @@ if ENABLE_TCTI_PCAP
- test_unit_tcti_pcap_CFLAGS = $(CMOCKA_CFLAGS) $(TESTS_CFLAGS)
- test_unit_tcti_pcap_LDADD = $(CMOCKA_LIBS) $(libtss2_mu) $(libutil)
- test_unit_tcti_pcap_LDFLAGS = -Wl,--wrap=getenv -Wl,--wrap=rand -Wl,--wrap=clock_gettime \
-- -Wl,--wrap=open -Wl,--wrap=read -Wl,--wrap=write -Wl,--wrap=close
-+ -Wl,--wrap=open -Wl,--wrap=read -Wl,--wrap=write -Wl,--wrap=close \
-+ -Wl,--wrap=__clock_gettime64
- test_unit_tcti_pcap_SOURCES = test/unit/tcti-pcap.c \
- src/tss2-tcti/tcti-common.c \
- src/tss2-tcti/tcti-pcap.c src/tss2-tcti/tcti-pcap.h \
-diff --git a/test/unit/tcti-pcap.c b/test/unit/tcti-pcap.c
-index c540de77..6fdc353e 100644
---- a/test/unit/tcti-pcap.c
-+++ b/test/unit/tcti-pcap.c
-@@ -288,6 +288,11 @@ __wrap_clock_gettime (clockid_t clk_id, struct timespec *tp)
- return EXIT_FAILURE;
- }
-
-+int
-+__wrap___clock_gettime64 (clockid_t clk_id, struct timespec *tp)
-+{
-+ return __wrap_clock_gettime(clk_id, tp);
-+}
-
- int
- __real_open (const char *pathname, int flags, mode_t mode);