aboutsummaryrefslogtreecommitdiffstats
path: root/community/ts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ts/APKBUILD')
-rw-r--r--community/ts/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/ts/APKBUILD b/community/ts/APKBUILD
new file mode 100644
index 00000000000..0843a7a44a5
--- /dev/null
+++ b/community/ts/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=ts
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="Simple Unix batch system"
+url="https://vicerveza.homeunix.net/~viric/soft/ts/"
+license="GPL-2.0-or-later"
+arch="all"
+checkdepends="bash"
+subpackages="$pkgname-doc"
+source="https://vicerveza.homeunix.net/~viric/soft/ts/ts-$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+check() {
+ ./testbench.sh >/dev/null
+}
+
+package() {
+ make PREFIX="$pkgdir"/usr install
+}
+
+sha512sums="
+031d57b5c903b6b71c9e4e2145325ec4204738fa4314f3f06343e0d8e721783480ade49913634c97a15f05e4f07600832677845873eb3549ac66c1ee13bcb247 ts-1.0.2.tar.gz
+"