aboutsummaryrefslogtreecommitdiffstats
path: root/community/tsocks
diff options
context:
space:
mode:
Diffstat (limited to 'community/tsocks')
-rw-r--r--community/tsocks/APKBUILD33
-rw-r--r--community/tsocks/configure.patch71
2 files changed, 104 insertions, 0 deletions
diff --git a/community/tsocks/APKBUILD b/community/tsocks/APKBUILD
new file mode 100644
index 00000000000..1765423a717
--- /dev/null
+++ b/community/tsocks/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Contributor: 7heo <7heo@mail.com>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=tsocks
+pkgver=1.8_beta5
+pkgrel=0
+pkgdesc="Transparent SOCKS proxying library"
+options="!check"
+url="http://tsocks.sourceforge.net/"
+arch="x86_64 ppc64le aarch64"
+license="GPL-2.0-or-later"
+subpackages="$pkgname-doc"
+source="https://downloads.sourceforge.net/tsocks/tsocks-${pkgver/_beta/beta}.tar.gz
+ configure.patch"
+builddir="$srcdir/$pkgname-${pkgver%_*}"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --libdir=/usr/lib
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b41636ea6b77abf0d1e3cda7bbca4e7ee96f3cdb1843f3a2c530650931e5567f67921de67b28ba9bab0f51df39770a3f7fb458cf7ac78aad7aa861923df2c4a9 tsocks-1.8beta5.tar.gz
+919479e359cafe4b331f5e5b058e0f07d1e6a37aa614891f9b16b4ea12a2358f8f42bb75c8cf9ebbecb223f88b1326e35f490c166247bd00d58e1eee57955800 configure.patch"
diff --git a/community/tsocks/configure.patch b/community/tsocks/configure.patch
new file mode 100644
index 00000000000..e33485ea7c4
--- /dev/null
+++ b/community/tsocks/configure.patch
@@ -0,0 +1,71 @@
+*** tsocks-1.8/configure Mon Jul 15 22:51:08 2002
+--- tsocks-1.8/configure.modified Thu Mar 26 18:34:09 2015
+***************
+*** 1299,1314 ****
+ fi
+
+
+! ac_safe=`echo "sys/poll.h" | sed 'y%./+-%__p_%'`
+! echo $ac_n "checking for sys/poll.h""... $ac_c" 1>&6
+! echo "configure:1305: checking for sys/poll.h" >&5
+ if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ cat > conftest.$ac_ext <<EOF
+ #line 1310 "configure"
+ #include "confdefs.h"
+! #include <sys/poll.h>
+ EOF
+ ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ { (eval echo configure:1315: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+--- 1299,1314 ----
+ fi
+
+
+! ac_safe=`echo "poll.h" | sed 'y%./+-%__p_%'`
+! echo $ac_n "checking for poll.h""... $ac_c" 1>&6
+! echo "configure:1305: checking for poll.h" >&5
+ if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ cat > conftest.$ac_ext <<EOF
+ #line 1310 "configure"
+ #include "confdefs.h"
+! #include <poll.h>
+ EOF
+ ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ { (eval echo configure:1315: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+***************
+*** 1330,1336 ****
+ :
+ else
+ echo "$ac_t""no" 1>&6
+! { echo "configure: error: "sys/poll.h not found"" 1>&2; exit 1; }
+ fi
+
+
+--- 1330,1336 ----
+ :
+ else
+ echo "$ac_t""no" 1>&6
+! { echo "configure: error: "poll.h not found"" 1>&2; exit 1; }
+ fi
+
+
+***************
+*** 2235,2241 ****
+ #line 2236 "configure"
+ #include "confdefs.h"
+
+! #include <sys/poll.h>
+ int poll($testproto);
+
+ int main() {
+--- 2235,2241 ----
+ #line 2236 "configure"
+ #include "confdefs.h"
+
+! #include <poll.h>
+ int poll($testproto);
+
+ int main() {