aboutsummaryrefslogtreecommitdiffstats
path: root/community/umbrello/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/umbrello/APKBUILD')
-rw-r--r--community/umbrello/APKBUILD52
1 files changed, 35 insertions, 17 deletions
diff --git a/community/umbrello/APKBUILD b/community/umbrello/APKBUILD
index a0edb864ce3..ab29b69450c 100644
--- a/community/umbrello/APKBUILD
+++ b/community/umbrello/APKBUILD
@@ -1,43 +1,61 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=umbrello
-pkgver=21.08.1
+pkgver=24.02.2
pkgrel=0
-arch="all !armhf !mips !mips64 !s390x !riscv64" # Blocked by extra-cmake-modules and rust
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://umbrello.kde.org/"
pkgdesc="GUI for diagramming Unified Modelling Language (UML)"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev karchive-dev kcompletion-dev kconfig-dev kcoreaddons-dev kcrash-dev kdoctools-dev ki18n-dev kiconthemes-dev kdelibs4support-dev kio-dev ktexteditor-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kitemmodels-dev"
+makedepends="
+ extra-cmake-modules
+ karchive5-dev
+ kcompletion5-dev
+ kconfig5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kio5-dev
+ kitemmodels5-dev
+ ktexteditor5-dev
+ kwidgetsaddons5-dev
+ kwindowsystem5-dev
+ kxmlgui5-dev
+ qt5-qtbase-dev
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/umbrello-$pkgver.tar.xz
- umbrello-20.08.3-no-qtwebkit.patch
- umbrello-unittests-no-qtwebkit.patch"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/sdk/umbrello.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/umbrello-$pkgver.tar.xz"
+options="!check" # Broken
case "$CARCH" in
ppc64le|armv7) options="!check";; # FIXME: testsuite fails
esac
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_KF5=ON
+ -DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-9ccba7ba2ac59df91d930baeca1e8841e31d790f6a590c8a03fd8a1e65818f7376281d6fe6770f0f60fd6f5958b8196a3dfe409a5e886becc864f18cc715a19d umbrello-21.08.1.tar.xz
-6437226d9d3970f6ac8e9b0a53546470e2235021a3e1d4d3339202ba1107259f26ef817760635f40a4cf3ff581f301f49a665c22ef1f070236885ef25bfb24a0 umbrello-20.08.3-no-qtwebkit.patch
-44581784270715d93a012d38d1a94b4f3c810bfddb24971c59c39874e16591a382a3753279021d5bd378ff6ede8f95a564acad88b8ae39b9885fe1c5e3932cb7 umbrello-unittests-no-qtwebkit.patch
+773d7682baf622d615a9e24f39431ba004b6b67a915d23b5873bf218499ec213bb62dcd8fd2a1ce94856a2157619f7f0de1f2e58544054b8a40382ae15af6367 umbrello-24.02.2.tar.xz
"