aboutsummaryrefslogtreecommitdiffstats
path: root/community/uncrustify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/uncrustify/APKBUILD')
-rw-r--r--community/uncrustify/APKBUILD35
1 files changed, 16 insertions, 19 deletions
diff --git a/community/uncrustify/APKBUILD b/community/uncrustify/APKBUILD
index 4891f366bcd..4b47fbe9b34 100644
--- a/community/uncrustify/APKBUILD
+++ b/community/uncrustify/APKBUILD
@@ -1,36 +1,33 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=uncrustify
-pkgver=0.69.0
-pkgrel=1
-pkgdesc="A source code beautifier"
+pkgver=0.78.1
+pkgrel=0
+pkgdesc="Source code beautifier"
url="https://github.com/uncrustify/uncrustify"
arch="all"
license="GPL-2.0-or-later"
-makedepends="cmake python3"
+makedepends="cmake python3 samurai"
subpackages="$pkgname-doc"
-source="https://downloads.sourceforge.net/uncrustify/uncrustify-$pkgver.tar.gz"
-builddir="$srcdir"
+source="$pkgname-$pkgver.tar.gz::https://github.com/uncrustify/uncrustify/archive/uncrustify-$pkgver.tar.gz"
+builddir="$srcdir/uncrustify-uncrustify-$pkgver"
build() {
- [ "$CARCH" = "s390x" ] && sed -i '/^12004/d' tests/c-sharp.test
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
check() {
- cd "$builddir/build"
- make test
+ ctest --test-dir build --output-on-failure
}
package() {
- install -d -m755 "$pkgdir"/usr/share/$pkgname
- install -m644 etc/*.cfg "$pkgdir"/usr/share/$pkgname
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ DESTDIR="$pkgdir" cmake --install build
- cd build
- make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm644 etc/*.cfg -t "$pkgdir"/usr/share/$pkgname
}
-sha512sums="ea6d8d55c9692ca80834f3f8493919251e8836f5020c2ffdc4d98558ab134df2002a5fd8f726ea7127bf9873623878a4a23b71a45441702766ee4f6df3d85003 uncrustify-0.69.0.tar.gz"
+sha512sums="
+51ebbc8b08212adea76565cdb578ceb9435769066d70ac14b55fbf0d66bcb34bfcc1cedd9c14c7bafe7b75be8795b3b59a076e40bbad9d242cb06ee9c0ac8638 uncrustify-0.78.1.tar.gz
+"