aboutsummaryrefslogtreecommitdiffstats
path: root/community/uncrustify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/uncrustify/APKBUILD')
-rw-r--r--community/uncrustify/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/community/uncrustify/APKBUILD b/community/uncrustify/APKBUILD
index 723034f4437..4b47fbe9b34 100644
--- a/community/uncrustify/APKBUILD
+++ b/community/uncrustify/APKBUILD
@@ -1,33 +1,33 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=uncrustify
-pkgver=0.72.0
+pkgver=0.78.1
pkgrel=0
pkgdesc="Source code beautifier"
url="https://github.com/uncrustify/uncrustify"
arch="all"
license="GPL-2.0-or-later"
-makedepends="cmake python3"
+makedepends="cmake python3 samurai"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/uncrustify/uncrustify/archive/uncrustify-$pkgver.tar.gz
- https://github.com/uncrustify/uncrustify/commit/45681e882d54aaa7defa15dfd2b5eaaa6856cb50.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/uncrustify/uncrustify/archive/uncrustify-$pkgver.tar.gz"
builddir="$srcdir/uncrustify-uncrustify-$pkgver"
build() {
- cmake -B build . \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
- make -C build
+ cmake --build build
}
check() {
- make -C build test ARGS="--output-on-failure"
+ ctest --test-dir build --output-on-failure
}
package() {
- make -C build DESTDIR="$pkgdir" PREFIX=/usr install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 etc/*.cfg -t "$pkgdir"/usr/share/$pkgname
}
-sha512sums="bfcbdf0d8198e1dd91f1c8283441a56669610a84d55a17cdd504571da09b26fef026fd3f753acd9950e498f574e6771a206c72b76ffdea97747b7a4fdb481862 uncrustify-0.72.0.tar.gz
-8feee9b2066a6ebad5616b78c7ad1ca0b778a047de68508fa2a45fa84e5983e380ae441e95ea5925bbac4bf600582dd29298886156352586cc4f319ea2e3329f 45681e882d54aaa7defa15dfd2b5eaaa6856cb50.patch"
+sha512sums="
+51ebbc8b08212adea76565cdb578ceb9435769066d70ac14b55fbf0d66bcb34bfcc1cedd9c14c7bafe7b75be8795b3b59a076e40bbad9d242cb06ee9c0ac8638 uncrustify-0.78.1.tar.gz
+"