aboutsummaryrefslogtreecommitdiffstats
path: root/community/unibilium
diff options
context:
space:
mode:
Diffstat (limited to 'community/unibilium')
-rw-r--r--community/unibilium/APKBUILD10
-rw-r--r--community/unibilium/build-static-lib.patch37
2 files changed, 42 insertions, 5 deletions
diff --git a/community/unibilium/APKBUILD b/community/unibilium/APKBUILD
index 534a285e6e5..64c0905e7ac 100644
--- a/community/unibilium/APKBUILD
+++ b/community/unibilium/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
pkgname=unibilium
pkgver=1.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="A terminfo parsing library"
url="https://github.com/mauke/unibilium/"
arch="all"
@@ -11,7 +11,8 @@ depends=""
depends_dev="libtool"
makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mauke/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mauke/$pkgname/archive/v$pkgver.tar.gz
+ build-static-lib.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -24,6 +25,5 @@ package() {
make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
}
-md5sums="9b1c97839a880a373da6c097443b43c4 unibilium-1.2.0.tar.gz"
-sha256sums="623af1099515e673abfd3cae5f2fa808a09ca55dda1c65a7b5c9424eb304ead8 unibilium-1.2.0.tar.gz"
-sha512sums="7aff79669200810c2910006aba657ca2276123ecb3e6e0ba01fa2d1c3cdf838c391594e6035ef150deb6185c4f1e43fe1b0bfb59b23c6697d801a5bdee37a0ee unibilium-1.2.0.tar.gz"
+sha512sums="7aff79669200810c2910006aba657ca2276123ecb3e6e0ba01fa2d1c3cdf838c391594e6035ef150deb6185c4f1e43fe1b0bfb59b23c6697d801a5bdee37a0ee unibilium-1.2.0.tar.gz
+68533c5e55997061ce71f1701490d078fd6a22ee83615d693e6b2fddda2d2b652ce73f5ff5335d3747f211845d4da4a80eb12733407ee071785624f94fa1d0e8 build-static-lib.patch"
diff --git a/community/unibilium/build-static-lib.patch b/community/unibilium/build-static-lib.patch
new file mode 100644
index 00000000000..643421f98d0
--- /dev/null
+++ b/community/unibilium/build-static-lib.patch
@@ -0,0 +1,37 @@
+--- a/Makefile
++++ b/Makefile
+@@ -45,6 +45,7 @@
+
+ OBJECTS=unibilium.lo uninames.lo uniutil.lo
+ LIBRARY=libunibilium.la
++LIBSTATIC=libunibilium.a
+
+ PODS=$(wildcard doc/*.pod)
+ MANPAGES=$(addprefix man/,$(notdir $(PODS:.pod=.3.gz)))
+@@ -54,7 +55,7 @@
+ TESTS=$(wildcard t/*.c)
+
+ .PHONY: all
+-all: $(LIBRARY) build-man build-tools build-test
++all: $(LIBRARY) $(LIBSTATIC) build-man build-tools build-test
+
+ %.lo: %.c unibilium.h
+ $(LIBTOOL) --mode=compile --tag=CC $(CC) -I. -Wall -std=c99 $(CFLAGS) $(CFLAGS_DEBUG) -o $@ -c $<
+@@ -65,6 +66,9 @@
+ $(LIBRARY): $(OBJECTS)
+ $(LIBTOOL) --mode=link --tag=CC $(CC) $(LDFLAGS) -rpath '$(LIBDIR)' -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -o $@ $^
+
++$(LIBSTATIC): $(OBJECTS)
++ $(LIBTOOL) --mode=link $(CC) -o $@ $^
++
+ tools/%: $(LIBRARY) tools/%.lo
+ $(LIBTOOL) --mode=link --tag=CC $(CC) $(LDFLAGS) -o $@ $^
+
+@@ -102,6 +106,7 @@
+ install-lib:
+ mkdir -p '$(DESTDIR)$(LIBDIR)'
+ $(LIBTOOL) --mode=install cp $(LIBRARY) '$(DESTDIR)$(LIBDIR)/$(LIBRARY)'
++ $(LIBTOOL) --mode=install install $(LIBSTATIC) $(DESTDIR)$(LIBDIR)/$(LIBSTATIC)
+
+ .PHONY: install-man
+ install-man: build-man