aboutsummaryrefslogtreecommitdiffstats
path: root/community/unpaper/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/unpaper/APKBUILD')
-rw-r--r--community/unpaper/APKBUILD36
1 files changed, 16 insertions, 20 deletions
diff --git a/community/unpaper/APKBUILD b/community/unpaper/APKBUILD
index 9084487f1fd..a85b256efd5 100644
--- a/community/unpaper/APKBUILD
+++ b/community/unpaper/APKBUILD
@@ -1,36 +1,32 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=unpaper
-pkgver=6.1
-pkgrel=2
-pkgdesc="post-processing tool for scanned sheets of paper"
-url="https://github.com/Flameeyes/unpaper"
+pkgver=7.0.0
+pkgrel=1
+pkgdesc="Post-processing tool for scanned sheets of paper"
+url="https://github.com/unpaper/unpaper"
arch="all"
license="GPL-2.0-only"
-makedepends="ffmpeg-dev automake autoconf libtool libxslt"
+makedepends="ffmpeg-dev meson py3-sphinx"
+checkdepends="py3-pillow py3-pytest"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/unpaper/unpaper/archive/unpaper-$pkgver.tar.gz"
-builddir="$srcdir/unpaper-unpaper-$pkgver"
+source="https://github.com/unpaper/unpaper/releases/download/unpaper-$pkgver/unpaper-$pkgver.tar.xz"
+options="!check" # they hang for some reason
build() {
- autoreconf -vif
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var
- make
+ abuild-meson . output
+ meson compile -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
check() {
- "$builddir"/unpaper --help > /dev/null
+ "$builddir"/output/unpaper --help
+ meson test --print-errorlogs --no-rebuild -C output
}
-sha512sums="3297cbade359f0ccb056619a41e6bc5fe675448ad65c6ff7a900084c01adc099457a9cb5a4fbd2ee95047f073dc3e557038bfcbb9169c535265b90df2e34db70 unpaper-6.1.tar.gz"
+sha512sums="
+58da969e773bf16ffee98b96f903ac5347f66d9a93c63bdb9131f5d45f4d7973c09f364ac2f27f8cb61f75de0421c6b01aa248fa9619fbdbde30fcebc76aa484 unpaper-7.0.0.tar.xz
+"