aboutsummaryrefslogtreecommitdiffstats
path: root/community/vifm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/vifm/APKBUILD')
-rw-r--r--community/vifm/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/vifm/APKBUILD b/community/vifm/APKBUILD
new file mode 100644
index 00000000000..fe257413dd2
--- /dev/null
+++ b/community/vifm/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=vifm
+pkgver=0.10.1
+pkgrel=0
+pkgdesc="ncurses vi-like file manager"
+options="!check" # runtests.log: make[4]: *** [Makefile:331: misc] Segmentation fault
+url="https://vifm.info/"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="ncurses-dev coreutils mdocml"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/vifm/$pkgname/archive/v$pkgver.tar.gz
+ perl-interpreter-fix.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --without-X11 \
+ --without-gtk \
+ --disable-build-timestamp
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f71e53414323d36768f128e12a4287aea3b065567818fe89c012e24fb427f5a44c12583691f8ab6e6aea51fbb6a3f65447c0d3b35b6224dc8f5a18274fc71cc5 vifm-0.10.1.tar.gz
+9aa55e00be8b8305184f16d76cb61cfc16ee90772c69c52d1b740f1fddbc2f7ea63a3586a0269c6bd6f5c5209c0956bec3a0c0094dc2a693390cde4c63ffa8d6 perl-interpreter-fix.patch"