aboutsummaryrefslogtreecommitdiffstats
path: root/community/vte3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/vte3/APKBUILD')
-rw-r--r--community/vte3/APKBUILD65
1 files changed, 43 insertions, 22 deletions
diff --git a/community/vte3/APKBUILD b/community/vte3/APKBUILD
index 1d615f9f8e8..61038c5bd7a 100644
--- a/community/vte3/APKBUILD
+++ b/community/vte3/APKBUILD
@@ -1,41 +1,62 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vte3
-pkgver=0.60.2
+pkgver=0.76.0
pkgrel=0
pkgdesc="Virtual Terminal Emulator library"
-url="https://developer.gnome.org/vte/"
+url="https://gitlab.gnome.org/GNOME/vte"
arch="all"
license="LGPL-2.0-or-later"
-subpackages="$pkgname-dev $pkgname-lang"
-makedepends="pango-dev gtk+3.0-dev intltool
- ncurses-dev gobject-introspection-dev vala gnutls-dev
- linux-headers libxml2-utils pcre2-dev gperf
- meson gtk-doc icu-dev"
-source="https://download.gnome.org/sources/vte/${pkgver%.*}/vte-$pkgver.tar.xz
+subpackages="$pkgname-dbg $pkgname-dev $pkgname-gtk4 $pkgname-lang"
+makedepends="
+ bash
+ gnutls-dev
+ gobject-introspection-dev
+ gperf
+ gtk+3.0-dev
+ gtk4.0-dev
+ gtk-doc
+ icu-dev
+ libxml2-utils
+ linux-headers
+ lz4-dev
+ meson
+ ncurses-dev
+ pango-dev
+ pcre2-dev
+ vala
+ "
+source="https://gitlab.gnome.org/GNOME/vte/-/archive/$pkgver/vte-$pkgver.tar.gz
fix-W_EXITCODE.patch
- vte-ng.patch"
+ "
+
builddir="$srcdir/vte-$pkgver"
build() {
- meson \
- --buildtype=plain \
+ abuild-meson \
+ -Dgtk4=true \
-Ddocs=false \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib/$pkgname \
-D_systemd=false \
. output
- ninja -C output
+ meson compile -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="801ac727cab33d2c3f4ba4d86bf7f19a82628acd2739196f24c85d038ba6bcc6a67239aac09141b8e0119a67f199ff8a8c653641a8e9aea1e8ab68bfd16017db vte-0.60.2.tar.xz
-94de7160b71f1c41aa19e8f9dc4538cd493da1a33dda6482c332f8e8932213631ccc2355506a616772dae451d653f035c66c721bd839570d6cb55e4d2b12e8a3 fix-W_EXITCODE.patch
-09caf90f7c280e484c40b4205d17b3921848dfb211b15f4126cca980eb7598c498dc0fd81fb38ca30c9f0bdab44fcb532819eab09b54d96badcffbf80695bb9b vte-ng.patch"
+
+gtk4() {
+ pkgdesc="$pkgdesc (gtk4 component)"
+
+ amove usr/bin/vte-*-gtk4
+ amove usr/lib/libvte-*-gtk4.so.*
+}
+
+sha512sums="
+2745aa716f7d0da292a67fcb06167cd3c729f79493030cf930dcc02f15de32cce230c401553280fbb566b6d501f253ca2466a93f887420844dc677e6162918d6 vte-0.76.0.tar.gz
+b6c1856bf075c2e3e91a0d4aff700c59e738bd6abe4122a11d680f104a2dab9d99f7d836a3ef3020b25ceff0a37231a6561eb917f0e4b9f90837eb634d8f7f20 fix-W_EXITCODE.patch
+"