aboutsummaryrefslogtreecommitdiffstats
path: root/community/wait4x/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/wait4x/APKBUILD')
-rw-r--r--community/wait4x/APKBUILD44
1 files changed, 32 insertions, 12 deletions
diff --git a/community/wait4x/APKBUILD b/community/wait4x/APKBUILD
index 9a05795ce22..3b8d0210e66 100644
--- a/community/wait4x/APKBUILD
+++ b/community/wait4x/APKBUILD
@@ -1,26 +1,46 @@
# Contributor: Mohammad Abdolirad <m.abdolirad@gmail.com>
# Maintainer: Mohammad Abdolirad <m.abdolirad@gmail.com>
pkgname=wait4x
-pkgver=0.4.0
-pkgrel=1
-pkgdesc="Waiting for a port to enter into specify state"
-url="https://github.com/atkrad/wait4x"
+pkgver=2.14.0
+pkgrel=2
+pkgdesc="Wait4X allows you to wait for a port or a service to enter the requested state"
+url="https://wait4x.dev"
arch="all"
-license="MIT"
+license="Apache-2.0"
makedepends="go"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
source="$pkgname-$pkgver.tar.gz::https://github.com/atkrad/wait4x/archive/v$pkgver.tar.gz"
options="!check" # Wait4X doesn't provide tests
-_commitsha="9fcfdc13"
-_commitdatetime="2020-12-21T19:05:13Z"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -v \
- -ldflags "-X github.com/atkrad/wait4x/internal/app/wait4x/cmd.AppVersion=v$pkgver -X github.com/atkrad/wait4x/internal/app/wait4x/cmd.GitCommit=$_commitsha -X github.com/atkrad/wait4x/internal/app/wait4x/cmd.BuildTime=$_commitdatetime" \
- -o bin/$pkgname cmd/wait4x/main.go
+ WAIT4X_COMMIT_REF_SLUG="v$pkgver" make build
+
+ ./dist/$pkgname completion bash > $pkgname.bash
+ ./dist/$pkgname completion fish > $pkgname.fish
+ ./dist/$pkgname completion zsh > $pkgname.zsh
}
package() {
- install -Dm755 "$builddir"/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm755 "$builddir"/dist/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 "$builddir"/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 $pkgname.bash \
+ "$pkgdir"/usr/share/bash-completion/completions/$pkgname
+ install -Dm644 $pkgname.fish \
+ "$pkgdir"/usr/share/fish/vendor_completions.d/$pkgname.fish
+ install -Dm644 $pkgname.zsh \
+ "$pkgdir"/usr/share/zsh/site-functions/_$pkgname
}
-sha512sums="8fbeae077321ca301b92120edc82cc4ad6f17cc173513c77c5334c6b266550e8e81a7e8d5154a6ac30697e349901e53fd44960c1b12bbeee1ba62d099d76abb5 wait4x-0.4.0.tar.gz"
+sha512sums="
+b42494e7b5b7cca21090c9baec3516a3f16b62381faa6473ceaafea3cd1af424e9fe935b405c18aa82a7bb6af70590a0f397aa41f2977104b7ac9a20fe388512 wait4x-2.14.0.tar.gz
+"