aboutsummaryrefslogtreecommitdiffstats
path: root/community/webhook/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/webhook/APKBUILD')
-rw-r--r--[-rwxr-xr-x]community/webhook/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/webhook/APKBUILD b/community/webhook/APKBUILD
index 46734c91b6e..9160271213d 100755..100644
--- a/community/webhook/APKBUILD
+++ b/community/webhook/APKBUILD
@@ -1,16 +1,18 @@
# Contributor: Andy Hawkins <andy@gently.org.uk>
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=webhook
-pkgver=2.8.0
-pkgrel=1
+pkgver=2.8.1
+pkgrel=6
pkgdesc="Lightweight configurable webhooks server"
url="https://github.com/adnanh/webhook"
license="MIT"
arch="all"
makedepends="go"
-source="https://github.com/adnanh/webhook/archive/$pkgver/webhook-$pkgver.tar.gz 10-fix-test.patch"
+source="https://github.com/adnanh/webhook/archive/$pkgver/webhook-$pkgver.tar.gz"
-export GOPATH="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
mkdir -p bin
@@ -25,5 +27,6 @@ package() {
install -Dm755 bin/webhook -t "$pkgdir"/usr/bin
}
-sha512sums="98a9e941687c1e679abd5cbd314dad28cb42383e483202698d386d9123d63a3f8f40bb97f3da2c644dfc3f79a8e7d7a6d28b5069c39c9ca114e7e101424481ca webhook-2.8.0.tar.gz
-1bc6c1fe18aa16df092a283e8a00954a60c910d25c53d3900b2657cf49d6aae59686e20565f58a52e7846f6ea200caf292cf39c265c14d083270a32d3f37354c 10-fix-test.patch"
+sha512sums="
+25edff21725ba9ac8823dbe5728234f7cd9218027e87df3e2482ef365a7dd0efe8659800233753c275f858ff87f848ff6141d09be3e0b66ff88b795680b9b635 webhook-2.8.1.tar.gz
+"