aboutsummaryrefslogtreecommitdiffstats
path: root/community/websocat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/websocat/APKBUILD')
-rw-r--r--community/websocat/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/websocat/APKBUILD b/community/websocat/APKBUILD
new file mode 100644
index 00000000000..1b013665942
--- /dev/null
+++ b/community/websocat/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
+pkgname=websocat
+pkgver=1.13.0
+pkgrel=0
+pkgdesc="Netcat, curl and socat for WebSockets"
+url="https://github.com/vi/websocat"
+arch="all"
+license="MIT"
+makedepends="cargo openssl-dev>3 cargo-auditable"
+options="net"
+source="https://github.com/vi/websocat/archive/v$pkgver/websocat-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ cargo fetch --target="$CTARGET" --locked
+}
+
+build() {
+ cargo auditable build --release --locked
+}
+
+check() {
+ cargo test --release --locked
+}
+
+package() {
+ install -D -m 0755 "target/release/websocat" -t "$pkgdir/usr/bin"
+}
+
+sha512sums="
+119cb6d0c226ed4f1df86a42a26903ba8465db30e5d0908d4a28601a58636e9a906fbb44d2d811ec9b25103a8c48b4ccea8b31f2f61854d062bc436ac6afac78 websocat-1.13.0.tar.gz
+"