aboutsummaryrefslogtreecommitdiffstats
path: root/community/whois/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/whois/APKBUILD')
-rw-r--r--community/whois/APKBUILD38
1 files changed, 23 insertions, 15 deletions
diff --git a/community/whois/APKBUILD b/community/whois/APKBUILD
index 64edc33a8a4..a5b0edb036a 100644
--- a/community/whois/APKBUILD
+++ b/community/whois/APKBUILD
@@ -1,38 +1,46 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=whois
-pkgver=5.5.4
+pkgver=5.5.22
pkgrel=0
pkgdesc="Intelligent WHOIS client by Marco d'Itri"
url="https://github.com/rfc1036/whois"
arch="all"
license="GPL-2.0-or-later"
-makedepends="perl libidn-dev gettext-dev"
+makedepends="perl libidn2-dev gettext-dev"
options="!check"
-subpackages="$pkgname-doc mkpasswd:_mkpasswd mkpasswd-doc"
-source="$pkgver-$pkgver.tar.gz::https://github.com/rfc1036/whois/archive/v$pkgver.tar.gz
+subpackages="$pkgname-doc mkpasswd:_mkpasswd"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rfc1036/whois/archive/v$pkgver.tar.gz
undefined-libintl.patch
enable-sha256-sha512-mkpasswd.patch
"
build() {
+ export CFLAGS="$CFLAGS -DHAVE_GETOPT_LONG -DHAVE_GETADDRINFO -DHAVE_SHA_CRYPT"
make CONFIG_FILE="/etc/whois.conf" HAVE_ICONV=1
}
+package() {
+ make BASEDIR="$pkgdir" install-whois
+ install -D -m644 whois.conf "$pkgdir/etc/whois.conf"
+
+ # Installed files are moved to a subpackage in _mkpasswd()
+ make BASEDIR="$pkgdir" install-mkpasswd
+
+ # Fix conflict with expect-doc
+ rm -f "$pkgdir"/usr/share/man/man1/mkpasswd.1
+}
+
_mkpasswd() {
depends="!expect"
pkgdesc="mkpasswd with configurable number of rounds"
- cd "$builddir"
- make BASEDIR="$subpkgdir" install-mkpasswd
- mkdir -p "$subpkgdir"-doc/usr
- mv "$subpkgdir"/usr/share "$subpkgdir"-doc/usr
-}
-package() {
- make BASEDIR="$pkgdir" install-whois
- install -D -m644 whois.conf "$pkgdir/etc/whois.conf"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/mkpasswd "$subpkgdir"/usr/bin
}
-sha512sums="f2fa92dc9490356c3584c2f9ac4e443dd4f57fbbeb0499fefc80af62665b886cb19d33ca55c5a8a0f9378588a646dfbd4dfda4da6c55681ba974b49ed93208d7 5.5.4-5.5.4.tar.gz
-efa32ec848e3d3e61481567815e8c02757eab32712eb5a431adb13b59fd359f735eb684fbdf8a5b8334410d17052dc93d65bdda27a328617e2b6772b23717487 undefined-libintl.patch
-66a6b36e4caa00d58ab44c8fb55bfe919994fc6c7631cc283d9f37f9d69bf3e911ab365b27b1720065103e8d7abbf7549dfb260e156c1b52726a8c8b8820c836 enable-sha256-sha512-mkpasswd.patch"
+sha512sums="
+b4e1088807e05729f76e48a0e7d0f4eb4560d934c99feffd73835c012a6a0d41a1b8c053ed5fbd1b7795f7771d1f23415aac4eeaea7ba990e2b3c6af8480efd1 whois-5.5.22.tar.gz
+7b066a41db4bb1b3753f9f390de05df6bbde27a0436c53ea2de47d87dbaf1182ce3dfc41459b49b3dc079b37ab1a21ea19118a283bd6b062a48ab3f6e2bfbbed undefined-libintl.patch
+71aaa2cb719fb76514263758b4e731bb6d9213b3174b1e5f1b17a531ececfb9d14acd5e8a2dfc2d776bb15b5cec2b67d9a1bae1c0009a91e8a2149d5b4f5012b enable-sha256-sha512-mkpasswd.patch
+"