aboutsummaryrefslogtreecommitdiffstats
path: root/community/wifish/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/wifish/APKBUILD')
-rw-r--r--community/wifish/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/community/wifish/APKBUILD b/community/wifish/APKBUILD
new file mode 100644
index 00000000000..8015aaa5f18
--- /dev/null
+++ b/community/wifish/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=wifish
+pkgver=1.1.4
+pkgrel=3
+pkgdesc="Simple wifi menu tool for wpa_supplicant"
+url="https://github.com/bougyman/wifish"
+options="!check" # Tests require running wpa_supplicant instance with wpa_cli
+arch="noarch"
+license="WTFPL"
+depends="wpa_supplicant gawk dialog"
+checkdepends="checkbashisms"
+source="$pkgname-$pkgver.tar.gz::https://github.com/bougyman/wifish/archive/$pkgver.tar.gz"
+
+package() {
+ install -Dm777 $pkgname "$pkgdir"/usr/bin/$pkgname
+ cd awk
+ for awk in *; do
+ install -Dm644 "$awk" "$pkgdir"/var/lib/wifish/"$awk"
+ done
+}
+
+sha512sums="5315ff3449a5e5162422997ec43946d1f4c441ba436484ae485ba3d6bd3d53f207ddd3d569112b2f1e8eb30f965f80aa5d651f2d07c031d140678274b22beced wifish-1.1.4.tar.gz"