aboutsummaryrefslogtreecommitdiffstats
path: root/community/wine/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/wine/APKBUILD')
-rw-r--r--community/wine/APKBUILD150
1 files changed, 104 insertions, 46 deletions
diff --git a/community/wine/APKBUILD b/community/wine/APKBUILD
index 605edd5f10a..c6af8a76b95 100644
--- a/community/wine/APKBUILD
+++ b/community/wine/APKBUILD
@@ -3,34 +3,96 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Contributor: Martell Malone <martell@marinelayer.io>
+# Contributor: Craig Andrews <candrews@integralblue.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wine
-pkgver=6.0
-_pkgver=${pkgver/_/-}
-pkgrel=1
-pkgdesc="A compatibility layer for running Windows programs"
+pkgver=9.0
+pkgrel=0
+pkgdesc="Compatibility layer for running Windows programs"
url="https://www.winehq.org"
arch="x86 x86_64"
license="LGPL-2.0-or-later"
-options="textrels !check" # As of 2.0.3 most of the tests fails
-subpackages="$pkgname-dev $pkgname-doc"
+depends="
+ libxi
+ libxrandr
+ "
depends_dev="$pkgname perl"
-makedepends="alsa-lib-dev autoconf automake bison cups-dev dbus-dev flex-dev
- fontconfig-dev freetype-dev gnutls-dev lcms-dev libjpeg-turbo-dev libpng-dev
- libxcomposite-dev libxcursor-dev libxdamage-dev libxi-dev libxinerama-dev
- libxml2-dev libxrandr-dev libxrender-dev libxslt-dev libxxf86dga-dev mesa-dev
- ncurses-dev openssl-dev tiff-dev udisks2-dev v4l-utils-dev zlib-dev
- vulkan-loader-dev vkd3d-dev
+makedepends="
+ alsa-lib-dev
+ autoconf
+ automake
+ bison
+ cups-dev
+ dbus-dev
+ flex-dev
+ fontconfig-dev
+ freetype-dev
+ gnutls-dev
+ gstreamer-dev
+ gst-plugins-base-dev
+ krb5-dev
+ libgphoto2-dev
+ libpcap-dev
+ libusb-dev
+ libxcomposite-dev
+ libxcursor-dev
+ libxi-dev
+ libxinerama-dev
+ libxkbcommon-dev
+ libxrandr-dev
+ libxrender-dev
+ mesa-dev
+ mingw-w64-gcc
+ ncurses-dev
+ opencl-dev
+ pcsc-lite-dev
+ pulseaudio-dev
+ sane-dev
+ sdl2-dev
+ udisks2-dev
+ v4l-utils-dev
+ vulkan-loader-dev
+ wayland-dev
"
+subpackages="$pkgname-dev $pkgname-doc"
checkdepends="xvfb-run"
-source="https://dl.winehq.org/wine/source/${pkgver%.[1-9]}/wine-$_pkgver.tar.xz
+source="https://dl.winehq.org/wine/source/9.0/wine-$pkgver.tar.xz
+ rpath.patch
"
+options="textrels !check" # As of 2.0.3 most of the tests fails
+# ignore tracing something in a weird rpath just to silence a warning
+# no effect
+somask="ntdll.so win32u.so"
+
+prepare() {
+ default_prepare
+ # fix opencl header detection
+ sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
+}
+
+case "$CARCH" in
+x86_64)
+ # also pull in 32-target, enabled with --enable-archs
+ makedepends="$makedepends i686-mingw-w64-gcc"
+ ;;
+esac
build() {
- local _win64 _no_pie
+ export CFLAGS="$CFLAGS -O2 -Wno-error=format-security"
+ export CXXFLAGS="$CXXFLAGS -O2 -Wno-error=format-security"
+ export CPPFLAGS="$CPPFLAGS -O2 -Wno-error=format-security"
+
+ # invalid to the msys linker
+ export LDFLAGS="${LDFLAGS/,-Wl,-z,pack-relative-relocs}"
+
case "$CARCH" in
- x86_64) _win64=--enable-win64;;
- x86) _no_pie="-no-pie";;
+ x86_64)
+ local win64="--enable-win64"
+ local archs="--enable-archs=x86_64,i386"
+ ;;
+ x86)
+ local no_pie="-no-pie"
+ ;;
esac
./configure \
--build=$CBUILD \
@@ -40,18 +102,12 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--with-dbus \
- --without-ldap \
+ --with-mingw \
--with-x \
- --with-vkd3d \
--with-vulkan \
- $_win64
- make LDFLAGS="$LDFLAGS $_no_pie" \
- tools/widl/widl \
- tools/winebuild/winebuild \
- tools/widl/widl \
- tools/winebuild/winebuild \
- tools/winegcc/winegcc \
- tools/wrc/wrc
+ $win64 \
+ $archs
+ make LDFLAGS="$LDFLAGS $no_pie" tools/winedump/winedump
make
}
@@ -60,46 +116,48 @@ check() {
}
package() {
- make -j1 DESTDIR="$pkgdir" install
-
- case "$CARCH" in
- x86_64) _wine="wine64";;
- *) _wine="wine";;
- esac
+ make DESTDIR="$pkgdir" install
install -Dm755 tools/wineapploader \
"$pkgdir"/usr/bin/wineapploader
local file
for file in msiexec notepad regedit regsvr32 wineboot \
- winecfg wineconsole winefile winemine winepath
- do
- rm "$pkgdir"/usr/bin/$file
- ln -sf /usr/bin/wineapploader "$pkgdir"/usr/bin/$file
+ winecfg wineconsole winefile winemine winepath; do
+ rm -v "$pkgdir"/usr/bin/$file
+ ln -sfv /usr/bin/wineapploader "$pkgdir"/usr/bin/$file
done
+
+ case "$CARCH" in
+ x86_64)
+ x86_64-w64-mingw32-strip --strip-unneeded "$pkgdir"/usr/lib/wine/x86_64-windows/*.dll
+ i686-w64-mingw32-strip --strip-unneeded "$pkgdir"/usr/lib/wine/i386-windows/*.dll
+
+ # add compat links, since with archs these rename back to non-64
+ ln -sfv wine "$pkgdir"/usr/bin/wine64
+ ln -sfv wine-preloader "$pkgdir"/usr/bin/wine64-preloader
+ ;;
+ x86)
+ i686-w64-mingw32-strip --strip-unneeded "$pkgdir"/usr/lib/wine/i386-windows/*.dll
+ ;;
+ esac
}
dev() {
default_dev
- install -d "$subpkgdir"/usr/bin
-
local file
for file in widl wmc wrc winebuild winedump function_grep.pl \
- winedbg winemaker winegcc winecpp wineg++
- do
- mv "$pkgdir"/usr/bin/$file "$subpkgdir"/usr/bin/
+ winedbg winemaker winegcc winecpp wineg++; do
+ amove usr/bin/$file
done
-
- install -d "$subpkgdir"/usr/lib/wine
- mv "$pkgdir"/usr/lib/wine/*.def "$subpkgdir"/usr/lib/wine/
}
doc() {
default_doc
rm -fr "$subpkgdir"/usr/share/man/*.UTF-8
}
-
sha512sums="
-c0732fbab1da8737d595a876b28ce87eef1440c317746e798642b59b44b34e890de562e0c0cc674e97096f39db82f8e9c3b1cc1ba9edc246b7266a0f7cb00057 wine-6.0.tar.xz
+838daf2c4581f83f8573b988036f517d57b84894b090a2a17433255d6d044dfa880e6724cdb83082a36c333df9d2083ab68ae53927622a620edd59f33462ada4 wine-9.0.tar.xz
+9881abfd0e7e4589cd5724291f9ec06ccb9d88b842c69abb5ea7865b6c27c778a060e60a9776c3620a030555cf61b8cceded55db9f04d5e45d9c627306763bff rpath.patch
"