aboutsummaryrefslogtreecommitdiffstats
path: root/community/wine
diff options
context:
space:
mode:
Diffstat (limited to 'community/wine')
-rw-r--r--community/wine/APKBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/community/wine/APKBUILD b/community/wine/APKBUILD
index 8afac6421e4..5fae70cec6b 100644
--- a/community/wine/APKBUILD
+++ b/community/wine/APKBUILD
@@ -3,13 +3,15 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wine
-pkgver=2.0.2
+pkgver=2.0.3
_pkgver=${pkgver/_/-}
pkgrel=0
pkgdesc="A compatibility layer for running Windows programs"
url="http://www.winehq.com"
arch="x86 x86_64"
license="LGPL2+"
+# As of 2.0.3 most of the tests fails
+options="!check"
subpackages="$pkgname-libs $pkgname-dev $pkgname-doc"
depends_dev="$pkgname perl"
makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
@@ -28,8 +30,8 @@ builddir="$srcdir/$pkgname-$_pkgver"
prepare() {
cd "$builddir"
- default_prepare || return 1
- aclocal && autoheader && autoreconf || return 1
+ default_prepare
+ aclocal && autoheader && autoreconf
}
build() {
@@ -47,15 +49,19 @@ build() {
--localstatedir=/var \
--with-dbus \
--with-x \
- $_win64 \
- || return 1
- make || return 1
+ $_win64
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
local file
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
case "$CARCH" in
x86_64) _wine="wine64";;
@@ -66,19 +72,19 @@ package() {
"$pkgdir"/usr/bin/$_wine
install -Dm755 tools/wineapploader \
- "$pkgdir"/usr/bin/wineapploader || return 1
+ "$pkgdir"/usr/bin/wineapploader
for file in msiexec notepad regedit regsvr32 wineboot \
winecfg wineconsole winefile winemine winepath
do
- rm "$pkgdir"/usr/bin/$file || return 1
+ rm "$pkgdir"/usr/bin/$file
ln -sf /usr/bin/wineapploader "$pkgdir"/usr/bin/$file
done
}
dev() {
local file
- default_dev || return 1
+ default_dev
install -d "$subpkgdir"/usr/bin
for file in widl wmc wrc winebuild winedump function_grep.pl \
@@ -92,13 +98,13 @@ dev() {
}
doc() {
- default_doc || return 1
+ default_doc
rm -fr "$subpkgdir"/usr/share/man/*.UTF-8
}
libs() {
local file ext
- default_libs || return 1
+ default_libs
install -d "$subpkgdir"/usr/lib/wine/fakedlls
for ext in dll16 drv16 exe16 acm dll drv ds ocx sys tlb vxd; do
@@ -111,6 +117,6 @@ libs() {
done
}
-sha512sums="3f37080a951819304cd3475f6012f1d6b5a94879b137cdf816cac4c8fde68ddc777905e92277ec5dce96437d8c32c43d55d3750b582781a9f9774b118f1a5b90 wine-2.0.2.tar.xz
+sha512sums="e20dbcb3a48ecb3526eba075d4baebab2529dfc50b7a6d5e18294704470f61db386013f457118c270274b911f9643d203110f46558d23e84e6a6c2d78e237dbb wine-2.0.3.tar.xz
d853875f7d659617bdfba364704abd75b760d12977f1f13acc73acb3c8fefec0549677fb79a4f8955e073d64078b3071d63d97262522e22b7832a66d3d820a9c no-pie.patch
522a94a31fc459e80ea7dd05f7aee64f6ae666ec05236d06614acde118d5c60002e0f253ae75edb5f02164f22937ca89578504b690d1a5611bd60f703c8f0c00 winhlp32-flex.patch"