aboutsummaryrefslogtreecommitdiffstats
path: root/community/wlc
diff options
context:
space:
mode:
Diffstat (limited to 'community/wlc')
-rw-r--r--community/wlc/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/community/wlc/APKBUILD b/community/wlc/APKBUILD
deleted file mode 100644
index 4a74677c0ed..00000000000
--- a/community/wlc/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
-pkgname=wlc
-pkgver=0.0.9
-pkgrel=0
-pkgdesc="Wayland Compositor Library"
-url="https://github.com/Cloudef/wlc"
-arch="all"
-license="MIT"
-depends="xkeyboard-config"
-makedepends="cmake eudev-dev libinput-dev libx11-dev libxkbcommon-dev mesa-dev
- pixman-dev wayland-dev wayland-protocols xcb-util-image-dev
- xcb-util-wm-dev"
-subpackages="$pkgname-dev"
-source="https://github.com/Cloudef/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2"
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- cmake . \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- || return 1
- make
-}
-
-check() {
- make test -C "$builddir"
-}
-
-package() {
- make DESTDIR="$pkgdir/" -C "$builddir" install
-}
-
-sha512sums="d34a29c779a39ffb95413f26c62d545f29ed7890529296b837bb153687600582dbe927c65558923bd1614c5fe904aa9cff760c272e79c6c0eff10ba38eee895b wlc-0.0.9.tar.bz2"