aboutsummaryrefslogtreecommitdiffstats
path: root/community/wlcs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/wlcs/APKBUILD')
-rw-r--r--community/wlcs/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/wlcs/APKBUILD b/community/wlcs/APKBUILD
index a9188699285..2b985d2c4f7 100644
--- a/community/wlcs/APKBUILD
+++ b/community/wlcs/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Luca Weiss <luca@z3ntu.xyz>
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname=wlcs
-pkgver=1.2.1
-pkgrel=1
+pkgver=1.3.0
+pkgrel=0
pkgdesc="Wayland Conformance Test Suite"
url="https://github.com/MirServer/wlcs"
arch="all"
@@ -10,7 +10,7 @@ license="GPL-3.0-only"
makedepends="cmake gtest-dev wayland-dev boost-dev"
subpackages="$pkgname-dev"
source="https://github.com/MirServer/wlcs/releases/download/v$pkgver/wlcs-$pkgver.tar.xz
- gtest.patch"
+ 0001-Fix-build-when-using-GTest-1.11.patch"
options="!check" # No test suite
build() {
@@ -33,5 +33,7 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="b6cb557e74ef835674b2cbea7e00e720ee44a47da379c68a2c49172d644222b9db8d62cbe3c706bb9c31b8e3600fb54b1729c35eb78c0e4239355d3af2b9b599 wlcs-1.2.1.tar.xz
-31239bae4bdbaaa15e355ee29f9d3e364439a85ac2915a91912c579481a006f4b45471745bc81ff1e873660547717be7025f7fcf16ed2ed31fea152655fb9371 gtest.patch"
+sha512sums="
+3c4ffd9fa1a087fe58912792f0747884bc42bb344be07e937079d399d2bf85c0e9e445880d8e503bad0028c48ffbf2338174c3c74faee5057bf62ff7f121f0de wlcs-1.3.0.tar.xz
+860caa3646525e08e42ec811dc6ed1124f2e22d3f3bd4f5979e89770ec430fe29f38445e8bda86228f3548631797316abc79925c912414370bdd74ddce109b2e 0001-Fix-build-when-using-GTest-1.11.patch
+"