aboutsummaryrefslogtreecommitdiffstats
path: root/community/wlcs
diff options
context:
space:
mode:
Diffstat (limited to 'community/wlcs')
-rw-r--r--community/wlcs/0001-Fix-build-when-using-GTest-1.11.patch52
-rw-r--r--community/wlcs/APKBUILD12
-rw-r--r--community/wlcs/gtest.patch16
3 files changed, 59 insertions, 21 deletions
diff --git a/community/wlcs/0001-Fix-build-when-using-GTest-1.11.patch b/community/wlcs/0001-Fix-build-when-using-GTest-1.11.patch
new file mode 100644
index 00000000000..c5fd4db78b8
--- /dev/null
+++ b/community/wlcs/0001-Fix-build-when-using-GTest-1.11.patch
@@ -0,0 +1,52 @@
+From f6ff93f7b7db154b7899f415ec67677e6ddd7ff5 Mon Sep 17 00:00:00 2001
+From: Victor Berger <victor.berger@m4x.org>
+Date: Thu, 8 Jul 2021 19:39:30 +0200
+Subject: [PATCH] Fix build when using GTest-1.11
+
+Some change in GTest 1.11 headers caused a conflict on the name
+`Pointer`. Removing the unconditional import of namespace `testing`
+in favor of individual imports of the used items fixes it.
+
+cc #205
+---
+ tests/pointer_constraints.cpp | 6 +++++-
+ tests/relative_pointer.cpp | 6 +++++-
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/tests/pointer_constraints.cpp b/tests/pointer_constraints.cpp
+index d306710..6ee856f 100644
+--- a/tests/pointer_constraints.cpp
++++ b/tests/pointer_constraints.cpp
+@@ -24,7 +24,11 @@
+
+ #include <memory>
+
+-using namespace testing;
++using testing::AnyNumber;
++using testing::Eq;
++using testing::Ne;
++using testing::NotNull;
++
+ using namespace wlcs;
+
+ namespace
+diff --git a/tests/relative_pointer.cpp b/tests/relative_pointer.cpp
+index c33316c..c5c5358 100644
+--- a/tests/relative_pointer.cpp
++++ b/tests/relative_pointer.cpp
+@@ -22,7 +22,11 @@
+
+ #include <gmock/gmock.h>
+
+-using namespace testing;
++using testing::AnyNumber;
++using testing::IsTrue;
++using testing::NotNull;
++using testing::_;
++
+ using namespace wlcs;
+
+ namespace
+--
+2.32.0
+
diff --git a/community/wlcs/APKBUILD b/community/wlcs/APKBUILD
index a9188699285..2b985d2c4f7 100644
--- a/community/wlcs/APKBUILD
+++ b/community/wlcs/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Luca Weiss <luca@z3ntu.xyz>
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname=wlcs
-pkgver=1.2.1
-pkgrel=1
+pkgver=1.3.0
+pkgrel=0
pkgdesc="Wayland Conformance Test Suite"
url="https://github.com/MirServer/wlcs"
arch="all"
@@ -10,7 +10,7 @@ license="GPL-3.0-only"
makedepends="cmake gtest-dev wayland-dev boost-dev"
subpackages="$pkgname-dev"
source="https://github.com/MirServer/wlcs/releases/download/v$pkgver/wlcs-$pkgver.tar.xz
- gtest.patch"
+ 0001-Fix-build-when-using-GTest-1.11.patch"
options="!check" # No test suite
build() {
@@ -33,5 +33,7 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="b6cb557e74ef835674b2cbea7e00e720ee44a47da379c68a2c49172d644222b9db8d62cbe3c706bb9c31b8e3600fb54b1729c35eb78c0e4239355d3af2b9b599 wlcs-1.2.1.tar.xz
-31239bae4bdbaaa15e355ee29f9d3e364439a85ac2915a91912c579481a006f4b45471745bc81ff1e873660547717be7025f7fcf16ed2ed31fea152655fb9371 gtest.patch"
+sha512sums="
+3c4ffd9fa1a087fe58912792f0747884bc42bb344be07e937079d399d2bf85c0e9e445880d8e503bad0028c48ffbf2338174c3c74faee5057bf62ff7f121f0de wlcs-1.3.0.tar.xz
+860caa3646525e08e42ec811dc6ed1124f2e22d3f3bd4f5979e89770ec430fe29f38445e8bda86228f3548631797316abc79925c912414370bdd74ddce109b2e 0001-Fix-build-when-using-GTest-1.11.patch
+"
diff --git a/community/wlcs/gtest.patch b/community/wlcs/gtest.patch
deleted file mode 100644
index 6d40e7add9d..00000000000
--- a/community/wlcs/gtest.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-https://github.com/MirServer/wlcs/pull/193
-
-diff --git a/cmake/FindGtestGmock.cmake b/cmake/FindGtestGmock.cmake
-index 230d988..34c514a 100644
---- a/cmake/FindGtestGmock.cmake
-+++ b/cmake/FindGtestGmock.cmake
-@@ -63,6 +63,9 @@ if (EXISTS ${GMOCK_SOURCE})
- else()
- # Assume gmock is no longer source, we'll find out soon enough if that's wrong
- add_custom_target(GMock)
-+ if (NOT DEFINED GTEST_LIBRARY)
-+ set(GTEST_LIBRARY ${GTEST_LIBRARIES})
-+ endif()
- string(REPLACE gtest gmock GMOCK_LIBRARY ${GTEST_LIBRARY})
- endif()
-