aboutsummaryrefslogtreecommitdiffstats
path: root/community/wlroots/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/wlroots/APKBUILD')
-rw-r--r--community/wlroots/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/wlroots/APKBUILD b/community/wlroots/APKBUILD
index 73e22d19a7a..ca39442689d 100644
--- a/community/wlroots/APKBUILD
+++ b/community/wlroots/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
-# Contributor: Drew DeVault <sir@cmpwn.com>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=wlroots
-pkgver=0.14.1
+pkgver=0.17.2
pkgrel=0
-pkgdesc="modular Wayland compositor library"
-url="https://github.com/swaywm/wlroots"
-arch="all !ppc64le !mips64" # blocked by libseat
+pkgdesc="Modular Wayland compositor library"
+url="https://gitlab.freedesktop.org/wlroots/wlroots"
license="MIT"
-options="!check" # contains no test suite
+arch="all"
makedepends="
eudev-dev
+ glslang-dev
+ hwdata-dev
libcap-dev
+ libdisplay-info-dev
libinput-dev
libseat-dev
libxcb-dev
@@ -20,22 +21,25 @@ makedepends="
meson
ninja
pixman-dev
+ vulkan-loader-dev
wayland-dev
wayland-protocols
xcb-util-image-dev
xcb-util-renderutil-dev
xcb-util-wm-dev
- xkeyboard-config
+ xkeyboard-config-dev
xwayland-dev
"
subpackages="$pkgname-dbg $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/wlroots/archive/$pkgver.tar.gz"
+source="https://gitlab.freedesktop.org/wlroots/wlroots/-/archive/$pkgver/wlroots-$pkgver.tar.gz"
+options="!check" # no test suite
build() {
abuild-meson \
+ -Db_lto=true \
-Dexamples=false \
. build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
package() {
@@ -43,5 +47,5 @@ package() {
}
sha512sums="
-4f557c827f9673eccf208a3644954de80e7355b95cc374cc5e851a47087b227f196e0936c0913d21a6c776c29b74de2d028a100931264e41934c747568d8ebe0 wlroots-0.14.1.tar.gz
+118361f4436371241215775ddc5b346f14a9d74e19d0642f724ed766bed8348d78ccc120ef806ac9393eb2cee8e97dde7041ed999a468db13a7176fc7d6fca9e wlroots-0.17.2.tar.gz
"