aboutsummaryrefslogtreecommitdiffstats
path: root/community/wob/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/wob/APKBUILD')
-rw-r--r--community/wob/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/community/wob/APKBUILD b/community/wob/APKBUILD
index 74dab779b77..d720e6acaef 100644
--- a/community/wob/APKBUILD
+++ b/community/wob/APKBUILD
@@ -1,15 +1,19 @@
# Contributor: Galen Abell <galen@galenabell.com>
# Maintainer: Galen Abell <galen@galenabell.com>
pkgname=wob
-pkgver=0.11
-pkgrel=0
-pkgdesc="A lightweight overlay volume/backlight/progress/anything bar for Wayland"
+pkgver=0.15.1
+pkgrel=1
+pkgdesc="Lightweight overlay volume/backlight/progress/anything bar for Wayland"
url="https://github.com/francma/wob"
arch="all"
license="ISC"
-makedepends="meson git wayland-protocols wayland-dev scdoc"
+makedepends="meson git inih-dev libseccomp-dev wayland-protocols wayland-dev scdoc"
+checkdepends="cmocka-dev"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/francma/wob/archive/$pkgver.tar.gz"
+source="
+ https://github.com/francma/wob/archive/$pkgver/wob-$pkgver.tar.gz
+ 0001-Fix-pledge-problem-on-armv7.patch
+ "
build() {
abuild-meson . output
@@ -24,4 +28,7 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="538d6a0aa756fa696e3caa326c6401f0b2fa9da4adbb4d519a01672bb23c9c1d6f8624a2416b5f6fb9f93bc94d13c2dc642a69835175bec11132031b7a0a0c01 wob-0.11.tar.gz"
+sha512sums="
+82cff4cb843ed2be7d47e6bc3d56b49242ddf76cd1c37aaba35d43ac22912b094bb213d7dc4ac49ef3862597b2f9ec3f07772c0d348c4e7f0afc961633aad2bb wob-0.15.1.tar.gz
+7a21f9526aa0bc00c092493fb2b8af09b9e0004ad8476be902821c134b7bee5e921e141cd4e11da78c321275a206c86d2a106f659fabecabfb7449e58bbfbaef 0001-Fix-pledge-problem-on-armv7.patch
+"