aboutsummaryrefslogtreecommitdiffstats
path: root/community/wslu
diff options
context:
space:
mode:
Diffstat (limited to 'community/wslu')
-rw-r--r--community/wslu/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/wslu/APKBUILD b/community/wslu/APKBUILD
index c5b09c25a84..4ffbb2beca0 100644
--- a/community/wslu/APKBUILD
+++ b/community/wslu/APKBUILD
@@ -1,18 +1,20 @@
# Maintainer: Jinming Wu, Patrick <me@patrickwu.space>
# Contributor: Jinming Wu, Patrick <me@patrickwu.space>
pkgname=wslu
-pkgver=3.2.2
-pkgrel=1
-pkgdesc="A collection of utilities for Windows 10 Linux Subsystems"
+pkgver=4.1.2
+pkgrel=0
+pkgdesc="collection of utilities for Windows Subsystems for Linux"
url="https://wslutiliti.es/wslu"
arch="noarch"
license="GPL-3.0-or-later"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
-depends="bc bash-completion imagemagick grep"
+depends="bc bash-completion-dev grep psmisc"
makedepends="gzip"
+checkdepends="bats"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/wslutilities/wslu/archive/v$pkgver.tar.gz"
-options="!check" #tests can be only run on a distro running on WSL(Windows Subsystems for Linux) environment, hence disabled
+# Testsuite needs to be run from inside WSL
+options="!check"
build() {
make
@@ -26,4 +28,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="12e90252656d2f614443dd29a504df654b7c7820015a14c97a0907cd5d6b312635b68c661438efd5a64a1b36323402eb0538a0cf4dbf8b9eaf71034f0aefed52 wslu-3.2.2.tar.gz"
+sha512sums="
+1c86081e6bdd153aa00f70f90917437a2b41609fa43942fa2cf6867006f37e13f1e486ead096e5bbaa0b1daf8f3493edc111687dc54f64b2db2875c1babaf789 wslu-4.1.2.tar.gz
+"