aboutsummaryrefslogtreecommitdiffstats
path: root/community/wuzz/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/wuzz/APKBUILD')
-rw-r--r--community/wuzz/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/wuzz/APKBUILD b/community/wuzz/APKBUILD
index ffb7882ce85..a8f3dada450 100644
--- a/community/wuzz/APKBUILD
+++ b/community/wuzz/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Adam Jensen <adam@acj.sh>
pkgname=wuzz
pkgver=0.5.0
-pkgrel=0
+pkgrel=22
pkgdesc="Interactive CLI tool for HTTP inspection"
options="net"
url="https://github.com/asciimoo/wuzz"
@@ -12,14 +12,21 @@ makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/asciimoo/wuzz/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
+export GOPATH="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
prepare() {
mkdir -p ${builddir%/*}
mv "$srcdir"/$pkgname-$pkgver "$builddir"/
default_prepare
+
+ go mod download
+ go mod tidy
}
build() {
- go mod download
go build -v
}
@@ -31,4 +38,6 @@ package() {
install -Dm755 "$builddir/$pkgname" -t "$pkgdir"/usr/bin/
}
-sha512sums="dbed0076d15e87e4b13d817fc02cf853a4c1fa96b6c3647507a86e47a26619f40120b72c8df8a4b6afd2472e552998d5fad292efa0d62ce9d63149e4379d7715 wuzz-0.5.0.tar.gz"
+sha512sums="
+dbed0076d15e87e4b13d817fc02cf853a4c1fa96b6c3647507a86e47a26619f40120b72c8df8a4b6afd2472e552998d5fad292efa0d62ce9d63149e4379d7715 wuzz-0.5.0.tar.gz
+"