aboutsummaryrefslogtreecommitdiffstats
path: root/community/wv/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/wv/APKBUILD')
-rw-r--r--community/wv/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/wv/APKBUILD b/community/wv/APKBUILD
new file mode 100644
index 00000000000..6eb1ad6949c
--- /dev/null
+++ b/community/wv/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wv
+pkgver=1.2.9
+pkgrel=7
+pkgdesc="A library that can load and parse Word 2000, 97, 95 and 6 file formats"
+url="https://sourceforge.net/projects/wvware/"
+arch="all"
+options="!check" # No test suite.
+license="GPL-2.0-or-later"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="libgsf-dev libpng-dev bzip2-dev coreutils"
+#source="http://www.abisource.com/downloads/wv/$pkgver/wv-$pkgver.tar.gz
+source="https://distfiles.alpinelinux.org/distfiles/edge/wv-$pkgver.tar.gz
+ werrorformat.patch
+ "
+
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+ae5c762012595ce8922bfda8749ad3e9cb055edab30152c3a5feaaf3ca6601f357d1e301b179e9a5860cd99452dd6e63e5f44f5bcc12f8db148bdd334e0200a5 wv-1.2.9.tar.gz
+b553db64d7bab2236a4bcbaa562e4d871193719e7f72571976d837bd454eb349c64dd256a77797059d5e6b9d0950b959097c9d3b3e50e2148a207a20bd92504d werrorformat.patch
+"