aboutsummaryrefslogtreecommitdiffstats
path: root/community/xapian-core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xapian-core/APKBUILD')
-rw-r--r--community/xapian-core/APKBUILD36
1 files changed, 19 insertions, 17 deletions
diff --git a/community/xapian-core/APKBUILD b/community/xapian-core/APKBUILD
index c545d247cd5..f33cab63019 100644
--- a/community/xapian-core/APKBUILD
+++ b/community/xapian-core/APKBUILD
@@ -1,32 +1,28 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=xapian-core
-pkgver=1.4.13
+pkgver=1.4.24
pkgrel=0
pkgdesc="Open source search engine library"
url="http://www.xapian.org/"
arch="all"
license="GPL-2.0-or-later"
-depends=""
-depends_dev="zlib-dev util-linux-dev"
-makedepends="$depends_dev libtool"
-install=""
+makedepends="zlib-dev util-linux-dev libtool"
subpackages="$pkgname-dev $pkgname-doc libxapian"
-source="http://oligarchy.co.uk/xapian/$pkgver/$pkgname-$pkgver.tar.xz
- timeval-t.patch"
-builddir="$srcdir"/$pkgname-$pkgver
+source="http://oligarchy.co.uk/xapian/$pkgver/xapian-core-$pkgver.tar.xz
+ timeval-t.patch
+ disable-failing-tests.patch"
+# FIXME: On armhf the sortableserialise1 test case fails.
case "$CARCH" in
-armhf) options="!check" ;; # FIXME
-s390x) options="!check" ;; # FIXME
+armhf) options="!check" ;;
esac
# secfixes:
# 1.4.6-r0:
-# - CVE-2018-0499
+# - CVE-2018-0499
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,21 +34,27 @@ build() {
}
check() {
- make VALGRIND= -C "$builddir" check
+ # Set AUTOMATED_TESTING here to skip tests which rely
+ # heavily on timing and may thus fail the face of uneven
+ # loads etc.
+ #
+ # See https://trac.xapian.org/ticket/764#comment:2
+ make AUTOMATED_TESTING=1 VALGRIND= -C "$builddir" check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
libxapian() {
pkgdesc="Xapian search engine library"
- cd "$builddir"
install -d "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/$subpkgname* "$subpkgdir"/usr/lib
}
-sha512sums="aa7b2262dd9d631339131e814f7c96acd85e386a4c4b6331eff86fc7227663589132779bd6b8c340a2b6f19bd66f8b53acbbe5bc985c74f9bdbe3ce3ccf4c1e7 xapian-core-1.4.13.tar.xz
-639c0ecd75be0627d334628b5adf581a7da92c4f86dfb86a92669368ff8a874d4bf4e344b8f3b1276d22d126d2bc44c8ab727e39e1c29c0358fe7bbc8aa8050d timeval-t.patch"
+sha512sums="
+2b156dd90784264d6bf64e66aca559578f946c013bb52e14e56fcd96e9c2fece71c236735b13d2baad0d7f2d410dea3ae54c94cd80f735baf1071bafe2e5c01c xapian-core-1.4.24.tar.xz
+639c0ecd75be0627d334628b5adf581a7da92c4f86dfb86a92669368ff8a874d4bf4e344b8f3b1276d22d126d2bc44c8ab727e39e1c29c0358fe7bbc8aa8050d timeval-t.patch
+a1a98befc36e148dce1f95b1f3b722d5d3d6d410575ce3d0b7d468f9596034d23b1fca47ec432ad03437ecd1eb09f0fc8d386340d266706766e067e0d1f24380 disable-failing-tests.patch
+"