aboutsummaryrefslogtreecommitdiffstats
path: root/community/xdg-desktop-portal-kde/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xdg-desktop-portal-kde/APKBUILD')
-rw-r--r--community/xdg-desktop-portal-kde/APKBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/community/xdg-desktop-portal-kde/APKBUILD b/community/xdg-desktop-portal-kde/APKBUILD
index aa1f0191d50..158e45e9db1 100644
--- a/community/xdg-desktop-portal-kde/APKBUILD
+++ b/community/xdg-desktop-portal-kde/APKBUILD
@@ -1,13 +1,14 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=xdg-desktop-portal-kde
-pkgver=5.21.5
+pkgver=6.0.3
pkgrel=0
pkgdesc="A backend implementation for xdg-desktop-portal that is using Qt/KDE"
# armhf blocked by extra-cmake-modules
-# s390x blocked by rust and pipewire
-arch="all !armhf !s390x"
-arch="$arch !mips !mips64 !s390x" # xdg-desktop-portal->flatpak->polkit
+arch="all !armhf"
url="https://phabricator.kde.org/source/xdg-desktop-portal-kde"
license="LGPL-2.0-or-later"
depends="xdg-desktop-portal"
@@ -18,13 +19,16 @@ makedepends="
kcoreaddons-dev
kdeclarative-dev
kio-dev
- kirigami2-dev
+ kirigami-dev
+ kstatusnotifieritem-dev
kwayland-dev
libepoxy-dev
pipewire-dev
- plasma-framework-dev
+ libplasma-dev
plasma-wayland-protocols
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
+ xdg-desktop-portal-dev
"
subpackages="$pkgname-lang"
@@ -32,20 +36,24 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/xdg-desktop-portal-kde-$pkgver.tar.xz"
+_repo_url="https://invent.kde.org/plasma/xdg-desktop-portal-kde.git"
+source="https://download.kde.org/stable/plasma/$pkgver/xdg-desktop-portal-kde-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_LIBEXECDIR=libexec
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ rm -rf "$pkgdir"/usr/lib/systemd
}
sha512sums="
-98fe44d4a00cb16f3e3ebd30b184e836dd77efafbca7625b555852b0dcd45c4ecf71ab5d93659e3d508f2b3b42696422516a08e2ae759bbe916fa5f9fef6010e xdg-desktop-portal-kde-5.21.5.tar.xz
+1f297332cbfce92c05e064cc073d67440c362f80975baee55804c17eb1d11ab19dc4771f6ce94435bb514f14b772038024b10bd2238cc02627765154b229d18a xdg-desktop-portal-kde-6.0.3.tar.xz
"