aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-input-evdev/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-input-evdev/APKBUILD')
-rw-r--r--community/xf86-input-evdev/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/xf86-input-evdev/APKBUILD b/community/xf86-input-evdev/APKBUILD
new file mode 100644
index 00000000000..7eeb4fc46c8
--- /dev/null
+++ b/community/xf86-input-evdev/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-input-evdev
+pkgver=2.10.6
+pkgrel=2
+pkgdesc="X.org evdev input driver"
+url="https://xorg.freedesktop.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc $pkgname-dev"
+makedepends="libxkbfile-dev xorg-server-dev libxi-dev libxrandr-dev
+ eudev-dev mtdev-dev libevdev-dev"
+source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="
+560b0a6491d50a46913a5890a35c0367e59f550670993493bd9712d712a9747ddaa6fe5086daabf2fcafa24b0159383787eb273da4a2a60c089bfc0a77ad2ad1 xf86-input-evdev-2.10.6.tar.bz2
+"