aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-amdgpu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-amdgpu/APKBUILD')
-rw-r--r--community/xf86-video-amdgpu/APKBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/community/xf86-video-amdgpu/APKBUILD b/community/xf86-video-amdgpu/APKBUILD
index 641ad964abc..55c2cefdff4 100644
--- a/community/xf86-video-amdgpu/APKBUILD
+++ b/community/xf86-video-amdgpu/APKBUILD
@@ -1,21 +1,30 @@
# Maintainer: Linus Swälas <linus.swalas@borderless.se>
pkgname=xf86-video-amdgpu
-pkgver=19.1.0
-pkgrel=0
+pkgver=23.0.0
+pkgrel=2
pkgdesc="AMD Rx/HDxxxx video driver"
url="https://xorg.freedesktop.org"
arch="all"
license="MIT"
subpackages="$pkgname-doc"
options="!check"
-depends="mesa-dri-ati"
-makedepends="xorg-server-dev libxi-dev libdrm-dev mesa-dev eudev-dev pixman-dev
- util-macros xorgproto libpciaccess-dev"
-source="https://www.x.org/releases/individual/driver/xf86-video-amdgpu-$pkgver.tar.bz2
- gcc-10.patch
+depends="mesa-dri-gallium"
+makedepends="
+ eudev-dev
+ libdrm-dev
+ libpciaccess-dev
+ libxi-dev
+ mesa-dev
+ pixman-dev
+ util-macros
+ xorg-server-dev
+ xorgproto
"
+source="https://www.x.org/releases/individual/driver/xf86-video-amdgpu-$pkgver.tar.xz"
build() {
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
@@ -34,5 +43,6 @@ package() {
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="ccdaa2378492da1a2f3d18fedacd1318c4708da534a8a959276a82730d5420619d83ad1ec8d7835c55655fe56123cd9bffb44e6223c5a97033c01f598af4a173 xf86-video-amdgpu-19.1.0.tar.bz2
-69922a73ed04d0aa7bca9a588a5b1a39833e7bdc66984b44b691a5163633952ee4ad4e741b7098d0642fe79d07784272dc8dfb010f63675e2586cb2dba6c15cf gcc-10.patch"
+sha512sums="
+bf26f147629a34e84a0ae8435119e170b9c95edafcab1995b63bb8f55abef32f2efbf4536eb070e64b2ae1460424b1b27a4206cb9836d33ddc6dfbee404f718b xf86-video-amdgpu-23.0.0.tar.xz
+"