aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-apm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-apm/APKBUILD')
-rw-r--r--community/xf86-video-apm/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/xf86-video-apm/APKBUILD b/community/xf86-video-apm/APKBUILD
index aa5cab9ca96..a9994cc9f46 100644
--- a/community/xf86-video-apm/APKBUILD
+++ b/community/xf86-video-apm/APKBUILD
@@ -1,18 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-apm
pkgver=1.3.0
-pkgrel=0
+pkgrel=4
pkgdesc="Alliance ProMotion video driver"
url="https://xorg.freedesktop.org/"
arch="all"
license="MIT"
subpackages="$pkgname-doc"
-depends=
makedepends="xorg-server-dev libxi-dev util-macros xorgproto"
source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
- cd "$builddir"
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
@@ -23,14 +28,14 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="1b10a2d1f886c228629487946fda1ff1766fe0c00657ba8cc1b4cf3bcd7cf66716a0875c90e6f7b7178cf3b48a78a4301bfad1714ee37c63aa7ae9c498ab4f8b xf86-video-apm-1.3.0.tar.bz2"
+sha512sums="
+1b10a2d1f886c228629487946fda1ff1766fe0c00657ba8cc1b4cf3bcd7cf66716a0875c90e6f7b7178cf3b48a78a4301bfad1714ee37c63aa7ae9c498ab4f8b xf86-video-apm-1.3.0.tar.bz2
+"