aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-ast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-ast/APKBUILD')
-rw-r--r--community/xf86-video-ast/APKBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/community/xf86-video-ast/APKBUILD b/community/xf86-video-ast/APKBUILD
index 2fb379ff34e..edf524114e4 100644
--- a/community/xf86-video-ast/APKBUILD
+++ b/community/xf86-video-ast/APKBUILD
@@ -1,20 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-ast
-pkgver=1.1.5
-pkgrel=4
+pkgver=1.1.6
+pkgrel=3
pkgdesc="X.Org driver for ASpeedTech cards"
url="https://xorg.freedesktop.org"
arch="all"
license="MIT"
-subpackages="$pkgname-doc"
-depends=
makedepends="xorg-server-dev libxi-dev util-macros xorgproto"
-source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
- "
+source="https://www.x.org/releases/individual/driver/xf86-video-ast-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -24,13 +21,13 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="067c2ce3e74c83fe1531213308753cb80482d177c93009c99dc49e95bfa6ff058d81cc716d6c343b9ca1e0eb7aedf3b84beb12ad08b8cd4d9f43e11f9e192e8e xf86-video-ast-1.1.5.tar.bz2"
+
+sha512sums="
+8482fec8d6be577f293cb820e623544475163f713fd74ec415f899bf5e9cf9453ffe4f96e141da3671437ebf616b47395d30d4b10858053c5893f5f5b7575ef1 xf86-video-ast-1.1.6.tar.xz
+"