aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-i740/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-i740/APKBUILD')
-rw-r--r--community/xf86-video-i740/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/xf86-video-i740/APKBUILD b/community/xf86-video-i740/APKBUILD
index ce9c3fb3517..85f7c493f87 100644
--- a/community/xf86-video-i740/APKBUILD
+++ b/community/xf86-video-i740/APKBUILD
@@ -1,21 +1,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-i740
pkgver=1.4.0
-pkgrel=0
+pkgrel=4
pkgdesc="Intel i740 video driver"
url="https://xorg.freedesktop.org"
arch="all"
license="MIT"
subpackages="$pkgname-doc"
-depends=
makedepends="xorg-server-dev libxi-dev util-macros xorgproto"
source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
"
-builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ update_config_sub
+}
build() {
- cd "$builddir"
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -25,14 +28,14 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="d34bcd1084de3173b65b9da4afc88435b153979ed4748cfa715d39f28fb238a21bbca7190a9091cdd9c67f55f98e4ae57980ef4dd7ca3dcfda373712f6bd0568 xf86-video-i740-1.4.0.tar.bz2"
+sha512sums="
+d34bcd1084de3173b65b9da4afc88435b153979ed4748cfa715d39f28fb238a21bbca7190a9091cdd9c67f55f98e4ae57980ef4dd7ca3dcfda373712f6bd0568 xf86-video-i740-1.4.0.tar.bz2
+"