aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-r128/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-r128/APKBUILD')
-rw-r--r--community/xf86-video-r128/APKBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/community/xf86-video-r128/APKBUILD b/community/xf86-video-r128/APKBUILD
index e7af3dc9c95..1a7d71ae0d7 100644
--- a/community/xf86-video-r128/APKBUILD
+++ b/community/xf86-video-r128/APKBUILD
@@ -1,20 +1,26 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-r128
-pkgver=6.12.0
-pkgrel=0
+pkgver=6.12.1
+pkgrel=3
pkgdesc="ATI Rage128 video driver"
url="https://xorg.freedesktop.org"
arch="all"
license="MIT"
subpackages="$pkgname-doc"
-depends=
-makedepends="xorg-server-dev libxi-dev libdrm-dev mesa-dev expat-dev util-macros
- autoconf automake libtool xorgproto"
-source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+makedepends="
+ expat-dev
+ libdrm-dev
+ libxi-dev
+ mesa-dev
+ util-macros
+ xorg-server-dev
+ xorgproto
+ "
+source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -25,14 +31,14 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="0e667e2cfa8a87a00846361d86528c93754c403c812b66798953fa4c857b2143b2c4c44885da467e7f910d8cb910b69492cdcb6f25e2197bae6617364d152e38 xf86-video-r128-6.12.0.tar.bz2"
+sha512sums="
+18b2408fe68161c32f84c7147717f8e6c6377e81e9d59e2f098843c54cd0ae757aab5059568da8c71ef38100807d56ee22447417c236c1b3deea292bb676e700 xf86-video-r128-6.12.1.tar.xz
+"