aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-savage/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-savage/APKBUILD')
-rw-r--r--community/xf86-video-savage/APKBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/community/xf86-video-savage/APKBUILD b/community/xf86-video-savage/APKBUILD
index 8389ff667d3..9cf3045c764 100644
--- a/community/xf86-video-savage/APKBUILD
+++ b/community/xf86-video-savage/APKBUILD
@@ -1,22 +1,26 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-savage
-pkgver=2.3.9
+pkgver=2.4.0
pkgrel=3
pkgdesc="S3 Savage video driver"
url="https://xorg.freedesktop.org"
arch="all"
license="MIT"
subpackages="$pkgname-doc"
-depends=
-makedepends="xorg-server-dev libxi-dev util-macros libdrm-dev mesa-dev
- xorgproto"
-source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
- 0001-Add-check-for-max-HV-Value-to-ValidMode-hook.patch
+makedepends="
+ libdrm-dev
+ libxi-dev
+ libxrandr-dev
+ mesa-dev
+ util-macros
+ xorg-server-dev
+ xorgproto
"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.xz"
build() {
- cd "$builddir"
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -26,14 +30,14 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="35fe52651fe5799bbbc6e7b3608a655102547e8f8f2189288d3f5b477f819bfc56a9a8eef39813ca455e56076e4f7c36304480c3ccddbac6c794672828cf705a xf86-video-savage-2.3.9.tar.bz2
-485112d65bf36be55eca607daf3f05f637b29826d3fb915f92158c3564f3033f40a6078be8626bd9ea7cef1cb6900fed054496d0f803a048fada905fb179235a 0001-Add-check-for-max-HV-Value-to-ValidMode-hook.patch"
+
+sha512sums="
+a4db097c200f1430887e4c52bbe14aeaaa2c73dfc392beeed104c682114bd067f89b69994d649829cdc5d188cdbe7a41b22c82b0b49e3a02cdf366013ebbc161 xf86-video-savage-2.4.0.tar.xz
+"