aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-sis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-sis/APKBUILD')
-rw-r--r--community/xf86-video-sis/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/community/xf86-video-sis/APKBUILD b/community/xf86-video-sis/APKBUILD
index 2eb83ce5cdd..c46c1364234 100644
--- a/community/xf86-video-sis/APKBUILD
+++ b/community/xf86-video-sis/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-sis
pkgver=0.12.0
-pkgrel=0
+pkgrel=4
pkgdesc="X.org SiS video driver"
url="https://xorg.freedesktop.org"
arch="all"
@@ -11,8 +11,14 @@ makedepends="xorg-server-dev util-macros mesa-dev libxi-dev xorgproto"
source="https://www.x.org/releases/individual/driver/xf86-video-sis-$pkgver.tar.bz2
fix-old-cpp-macros.patch
"
+prepare() {
+ default_prepare
+ update_config_sub
+}
build() {
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
@@ -30,5 +36,7 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="5aa101e5217f15667f2c94f7a76f4afcf47717b61f5d206ce65efe35dc3f674ca294f98ca8586971c6467f31decdd94d8255ebfc7dc220fac0179afc61995952 xf86-video-sis-0.12.0.tar.bz2
-d4262ac8c17d04547473df260518247afb09a5bf6ddbe85d7877534f1e99d316d52fb933839f56a4e61b3706b124fa91c6926d432ba542e525f2007af253ff2a fix-old-cpp-macros.patch"
+sha512sums="
+5aa101e5217f15667f2c94f7a76f4afcf47717b61f5d206ce65efe35dc3f674ca294f98ca8586971c6467f31decdd94d8255ebfc7dc220fac0179afc61995952 xf86-video-sis-0.12.0.tar.bz2
+d4262ac8c17d04547473df260518247afb09a5bf6ddbe85d7877534f1e99d316d52fb933839f56a4e61b3706b124fa91c6926d432ba542e525f2007af253ff2a fix-old-cpp-macros.patch
+"