aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-sunleo
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-sunleo')
-rw-r--r--community/xf86-video-sunleo/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/xf86-video-sunleo/APKBUILD b/community/xf86-video-sunleo/APKBUILD
new file mode 100644
index 00000000000..dbf12191cca
--- /dev/null
+++ b/community/xf86-video-sunleo/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-sunleo
+pkgver=1.2.2
+pkgrel=3
+pkgdesc="Leo video driver"
+url="https://xorg.freedesktop.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=
+makedepends="xorg-server-dev libxi-dev util-macros xorgproto"
+source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
+ "
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+sha512sums="467559e608b59dcf2a50cbaddc218ad0778e88515906fed9d6346db09187f3f7645482113882bcf81428d4af3d3f2cccec7f24663c12c23a411f8a87551ef23f xf86-video-sunleo-1.2.2.tar.bz2"