aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-tdfx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-tdfx/APKBUILD')
-rw-r--r--community/xf86-video-tdfx/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/community/xf86-video-tdfx/APKBUILD b/community/xf86-video-tdfx/APKBUILD
index 0dc9655761f..18f4833b9fc 100644
--- a/community/xf86-video-tdfx/APKBUILD
+++ b/community/xf86-video-tdfx/APKBUILD
@@ -1,21 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-tdfx
pkgver=1.5.0
-pkgrel=0
+pkgrel=4
pkgdesc="3Dfx video driver"
url="https://xorg.freedesktop.org"
arch="all"
license="MIT"
subpackages="$pkgname-doc"
-depends=
makedepends="xorg-server-dev libxi-dev util-macros libdrm-dev mesa-dev
xorgproto"
source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
"
-builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
- cd "$builddir"
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -25,14 +29,14 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="eca3359c7db56183a1cfcce7295e41ccc349005ee1cbcf75209f1e4e8e04e887ba511712ef35efc11c940713c8327b0b8ab8b6c86facf02062b3e84c0b1af5ff xf86-video-tdfx-1.5.0.tar.bz2"
+sha512sums="
+eca3359c7db56183a1cfcce7295e41ccc349005ee1cbcf75209f1e4e8e04e887ba511712ef35efc11c940713c8327b0b8ab8b6c86facf02062b3e84c0b1af5ff xf86-video-tdfx-1.5.0.tar.bz2
+"