aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-vesa/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xf86-video-vesa/APKBUILD')
-rw-r--r--community/xf86-video-vesa/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/xf86-video-vesa/APKBUILD b/community/xf86-video-vesa/APKBUILD
index bb1e3b913ca..c2fe691f6b9 100644
--- a/community/xf86-video-vesa/APKBUILD
+++ b/community/xf86-video-vesa/APKBUILD
@@ -1,16 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-vesa
-pkgver=2.5.0
-pkgrel=0
+pkgver=2.6.0
+pkgrel=4
pkgdesc="X.org generic VESA video driver"
url="https://xorg.freedesktop.org/wiki/"
arch="all"
license="MIT"
subpackages="$pkgname-doc"
makedepends="xorg-server-dev libxi-dev util-macros xorgproto"
-source="https://www.x.org/releases/individual/driver/xf86-video-vesa-$pkgver.tar.bz2"
+source="https://www.x.org/releases/individual/driver/xf86-video-vesa-$pkgver.tar.xz"
build() {
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -27,4 +29,7 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="36fd921f54f33eb25966b5f9ea1e1b3e9009965c012c8b9c676686b472111719921b80cf62dafc746058878253e21f0ef341a2ff2d650df22ca1e35e81716a8b xf86-video-vesa-2.5.0.tar.bz2"
+
+sha512sums="
+494e117c1e6e0ce4c66ac7798de54667862c62605bfd76dd9373447d40dcd0521100810c9285cbe9c159440e217954c0cad6d5219c5894e075509c7c0bc353c7 xf86-video-vesa-2.6.0.tar.xz
+"