aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfwm4-themes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xfwm4-themes/APKBUILD')
-rw-r--r--community/xfwm4-themes/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/xfwm4-themes/APKBUILD b/community/xfwm4-themes/APKBUILD
new file mode 100644
index 00000000000..179b7787370
--- /dev/null
+++ b/community/xfwm4-themes/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfwm4-themes
+pkgver=4.10.0
+pkgrel=0
+pkgdesc="A set of additionnal themes for the Xfce window manager"
+url="https://xfce.org/"
+arch="noarch"
+license="GPL-2.0"
+depends="xfwm4"
+makedepends=
+options="!strip"
+source="http://archive.xfce.org/src/art/xfwm4-themes/${pkgver%.*}/xfwm4-themes-${pkgver}.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+sha512sums="5c77e9f1b4b1051f86696605d2fcc8ba6abbc667fc2ae48c5eb1235d62fb99e5171a7c8b9b662147e86b1f508fd8d723f931bd211e41675ab390ec0d7a5e1305 xfwm4-themes-4.10.0.tar.bz2"