aboutsummaryrefslogtreecommitdiffstats
path: root/community/xorg-server/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xorg-server/APKBUILD')
-rw-r--r--community/xorg-server/APKBUILD124
1 files changed, 77 insertions, 47 deletions
diff --git a/community/xorg-server/APKBUILD b/community/xorg-server/APKBUILD
index 4c5fc38a043..72ed0cccc31 100644
--- a/community/xorg-server/APKBUILD
+++ b/community/xorg-server/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xorg-server
-pkgver=1.20.13
+pkgver=21.1.13
pkgrel=0
pkgdesc="X.Org X servers"
url="https://www.x.org/wiki"
@@ -17,55 +17,90 @@ subpackages="
$pkgname-xnest
$pkgname-common::noarch
"
-# the modesetting driver is now shipped with xorg server
-replaces="xf86-video-modesetting"
depends="
- font-misc-misc
font-cursor-misc
- xkeyboard-config
+ font-misc-misc
+ mesa-egl
xkbcomp
- xinit
+ xkeyboard-config
xorg-server-common
"
depends_dev="
libepoxy-dev
+ libpciaccess-dev
libxfont2-dev
mesa-dev
- libpciaccess-dev
"
makedepends="
$depends_dev
- meson
- xorgproto
- xtrans
- libxshmfence-dev
- pixman-dev
- xkbcomp-dev
- libxkbfile-dev
- nettle-dev
- wayland-dev
- wayland-protocols
+ eudev-dev
libdrm-dev
- libxext-dev
libx11-dev
libxau-dev
- eudev-dev
libxcb-dev
+ libxcvt-dev
+ libxdmcp-dev
+ libxext-dev
+ libxkbfile-dev
+ libxshmfence-dev
+ meson
+ nettle-dev
+ pixman-dev
+ wayland-dev
+ wayland-protocols
xcb-util-dev
xcb-util-image-dev
xcb-util-keysyms-dev
xcb-util-renderutil-dev
xcb-util-wm-dev
- libxdmcp-dev
+ xkbcomp-dev
+ xorgproto
+ xtrans
"
source="https://www.x.org/releases/individual/xserver/xorg-server-$pkgver.tar.xz
- link-libshadow.patch
- e50c85f4ebf559a3bac4817b41074c43d4691779.patch
- 0001-compiler.h-ensure-IOPortBase-is-declared-extern-on-m.patch
- meson-install-xorg-wrap-script.patch
- "
+ ms-rotate.patch"
+
+# the modesetting driver is now shipped with xorg server
+provides="xf86-video-modesetting=$pkgver-r$pkgrel"
+replaces="xf86-video-modesetting"
# secfixes:
+# 21.1.12-r0:
+# - CVE-2024-31080
+# - CVE-2024-31081
+# - CVE-2024-31082
+# - CVE-2024-31083
+# 21.1.11-r0:
+# - CVE-2023-6816
+# - CVE-2024-0229
+# - CVE-2024-21885
+# - CVE-2024-21886
+# - CVE-2024-0408
+# - CVE-2024-0409
+# 21.1.10-r0:
+# - CVE-2023-6377
+# - CVE-2023-6478
+# 21.1.9-r0:
+# - CVE-2023-5367
+# - CVE-2023-5380
+# - CVE-2023-5574
+# 21.1.7-r0:
+# - CVE-2023-0494
+# 21.1.5-r0:
+# - CVE-2022-4283
+# - CVE-2022-46340
+# - CVE-2022-46341
+# - CVE-2022-46342
+# - CVE-2022-46343
+# - CVE-2022-46344
+# 21.1.4-r0:
+# - CVE-2022-2319
+# - CVE-2022-2320
+# 21.1.2-r0:
+# - CVE-2021-4008
+# - CVE-2021-4009
+# - CVE-2021-4010
+# - CVE-2021-4011
# 1.20.10-r5:
# - CVE-2021-3472
# 1.20.10-r0:
@@ -105,18 +140,20 @@ build() {
# xorg modules does not work with the -z now and it seems like we
# cannot pass over the linker flag to .so files. so we tweak the
# gcc specs.
- export CFLAGS="$CFLAGS -D_GNU_SOURCE -D__gid_t=gid_t -D__uid_t=uid_t"
+ export CFLAGS="${CFLAGS/-fno-plt}"
+ export CXXFLAGS="${CXXFLAGS/-fno-plt}"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
_fontroot="/usr/share/fonts"
+ # 32-bit fails otherwise
+ export CFLAGS="$CFLAGS -Wno-error=array-bounds"
+
abuild-meson \
+ -Db_lto=true \
-Dxorg=true \
-Dxephyr=true \
- -Dxwayland=false \
-Dglamor=true \
- -Dxwayland_eglstream=false \
-Dxnest=true \
- -Ddmx=false \
-Dxvfb=true \
-Dxwin=false \
-Ddefault_font_path=$_fontroot/misc,$_fontroot/100dpi:unscaled,$_fontroot/75dpi:unscaled,$_fontroot/TTF,$_fontroot/Type1 \
@@ -128,7 +165,6 @@ build() {
-Dipv6=true \
-Dxkb_dir=/usr/share/X11/xkb \
-Dxkb_output_dir=/var/lib/xkb \
- -Dos_vendor="${DISTRO_NAME:-Alpine Linux}" \
-Dlisten_tcp=false \
-Dlisten_unix=true \
-Dlisten_local=true \
@@ -142,41 +178,40 @@ build() {
-Ddri2=true \
-Ddri3=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
chmod u+s "$pkgdir"/usr/libexec/Xorg.wrap
- ln -s /usr/bin/Xorg "$pkgdir"/usr/bin/X
# Don't conflict with xf86-input-evdev
rm -f "$pkgdir"/usr/share/X11/xorg.conf.d/10-evdev.conf
- install -m755 -d "$pkgdir"/var/lib/xkb
+ install -Dm0644 xkb/README.compiled -t "$pkgdir"/var/lib/xkb
}
xvfb() {
pkgdesc="Virtual Framebuffer 'fake' X server"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/Xvfb "$subpkgdir"/usr/bin/
+
+ amove usr/bin/Xvfb
}
xephyr() {
pkgdesc="kdrive based X Server which targets a window on a host X Server as its framebuffer"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/Xephyr "$subpkgdir"/usr/bin/
+
+ amove usr/bin/Xephyr
}
xnest() {
pkgdesc="A nested Xorg server"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/Xnest "$subpkgdir"/usr/bin/
+
+ amove usr/bin/Xnest
}
common() {
@@ -184,14 +219,9 @@ common() {
pkgdesc="Xorg server common files"
amove usr/lib/xorg/protocol.txt
-
- install -Dm0644 "$builddir"/xkb/README.compiled -t "$pkgdir"/var/lib/xkb
}
sha512sums="
-4e0b7bd4e070dc52cb2c51c2056feb133de2c0487d359392ed63abba9702910cd2e2983e9415973d8d6e9672eac78be6f39202687fc56610877914ce722554b3 xorg-server-1.20.13.tar.xz
-d0f723e6033a77faec118adc64e9d4749270724cbb2b86ca5ff796e1fbaef2d01ebcbb2904d48132b58f3ecf0781b2583744b671b17b7d51a1748f4b461932b0 link-libshadow.patch
-e1a4c630e2bbf9ab47c81d48f2de98e302a0e3d5c2896d07804dc36eef1cd0a4e076bd2ed1be70c0d3b024501e5f540abf1b11548ede74c1af3c82183553a728 e50c85f4ebf559a3bac4817b41074c43d4691779.patch
-a91f861588233c363a7939194d1582114ea216117e5f046b971d6571cb79445ceaaf0a1c6f66781da5b139d9ab8bd260d5dc3ff8c3279410865807561bf4fcee 0001-compiler.h-ensure-IOPortBase-is-declared-extern-on-m.patch
-748e02370ba38bfa02b5e3bc503ad46d6c1fe8c59c7c0288f860a960089d3a6367b57cfcb999b6b354a08bae537baab86f12aed8ecdc381427a8126c4dd3097b meson-install-xorg-wrap-script.patch
+a55fbeeed227c12c67f166f2c06a7f4f8d78feeea04c6e73509dbc723185fd0772349aa23f7c44cf0828ac0a0e2f9e4b26cffb220e6dfa7186d60f88b25ccaf1 xorg-server-21.1.13.tar.xz
+9ed9c731a7275a3821476eedd55f453027fdf9bcdfd8f259259a5d053c73e8b9298f048cbb009a4fb05230fb2a9ab7cc38a44d708973f09daa8570fae376236e ms-rotate.patch
"