aboutsummaryrefslogtreecommitdiffstats
path: root/community/xprop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xprop/APKBUILD')
-rw-r--r--community/xprop/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/xprop/APKBUILD b/community/xprop/APKBUILD
new file mode 100644
index 00000000000..5f92bc2eada
--- /dev/null
+++ b/community/xprop/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xprop
+pkgver=1.2.7
+pkgrel=0
+pkgdesc="Property displayer for X"
+url="https://cgit.freedesktop.org/xorg/app/xprop"
+arch="all"
+license="MIT"
+makedepends="libx11-dev util-macros"
+subpackages="$pkgname-doc"
+source="https://www.x.org/archive/individual/app/xprop-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+84ada23660e2aef7024352e1a774f920e86c55fbfda486c087b9f41f8da30a84734fe753b62432f3df16913e86da4a18ce04ca018091d444cef727de97bf94f1 xprop-1.2.7.tar.xz
+"