aboutsummaryrefslogtreecommitdiffstats
path: root/community/yamllint/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/yamllint/APKBUILD')
-rw-r--r--community/yamllint/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/community/yamllint/APKBUILD b/community/yamllint/APKBUILD
index 92ee3a75a84..2fa6773c5f4 100644
--- a/community/yamllint/APKBUILD
+++ b/community/yamllint/APKBUILD
@@ -1,19 +1,26 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=yamllint
-pkgver=1.26.1
-pkgrel=0
+pkgver=1.35.1
+pkgrel=1
pkgdesc="A linter for YAML files"
url="https://github.com/adrienverge/yamllint"
arch="noarch"
license="GPL-3.0-or-later"
depends="python3 py3-pathspec py3-yaml"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://github.com/adrienverge/yamllint/archive/v$pkgver/yamllint-$pkgver.tar.gz
skip-locale-tests.patch"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -21,10 +28,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-d1c1e73d59cd2d64af51cb048cc991f3b83eb2352c76c24a62c8fd526275fba13359553ee5f51012eaefd63c51b284c1c3c3d855d333d6355208e73447edb0f7 yamllint-1.26.1.tar.gz
+1e19fdfa1041aaa821ad98299d08c61f7f0b698f929fba7eab93590f92a6011df80124a4d7cab462d2e135bfd0c3538b20ca1498d8ddb3929d0c58871f51a9ae yamllint-1.35.1.tar.gz
abf8e7089ffa29efd8cea682d7b1178a3a93a5f1158bdf6d058437308e2dce33b72278a303b5a1b9e7dc57040c414ba7945c19b0500788cd3426c9192bce5440 skip-locale-tests.patch
"