aboutsummaryrefslogtreecommitdiffstats
path: root/community/yash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/yash/APKBUILD')
-rw-r--r--community/yash/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/community/yash/APKBUILD b/community/yash/APKBUILD
index c9e15ff30bc..1cf22ca625b 100644
--- a/community/yash/APKBUILD
+++ b/community/yash/APKBUILD
@@ -7,9 +7,10 @@ pkgdesc="Yet another shell"
url="http://yash.osdn.jp"
arch="all"
license="GPL-2.0-or-later"
+depends="$pkgname-completion"
makedepends="ncurses-dev"
install="$pkgname.post-install $pkgname.pre-deinstall"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-completion::noarch $pkgname-doc"
source="https://github.com/magicant/yash/releases/download/$pkgver/yash-$pkgver.tar.xz"
prepare() {
@@ -44,4 +45,11 @@ package() {
rm -Rf "$pkgdir"/usr/share/man/ja
}
+completion() {
+ pkgdesc="$pkgdesc (command-line completion)"
+ depends=""
+
+ amove usr/share/yash/completion
+}
+
sha512sums="99d98cfbe09aa746f2707217ecb506d8d5998df4a603ac276a8a67782fdcb3a7bd41fb34744f3834e319b0fdb0b1fd480cf9e2a4b835fec3e758280e13036db5 yash-2.49.tar.xz"