aboutsummaryrefslogtreecommitdiffstats
path: root/community/zathura-ps
diff options
context:
space:
mode:
Diffstat (limited to 'community/zathura-ps')
-rw-r--r--community/zathura-ps/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/community/zathura-ps/APKBUILD b/community/zathura-ps/APKBUILD
index a3baf3e53a4..de45c46d1f3 100644
--- a/community/zathura-ps/APKBUILD
+++ b/community/zathura-ps/APKBUILD
@@ -2,27 +2,29 @@
# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
pkgname=zathura-ps
-pkgver=0.2.5
+pkgver=0.2.6
pkgrel=0
pkgdesc="zathura-ps - plugin adds PostScript support to zathura"
url="https://pwmt.org/projects/$pkgname"
arch="all"
license="zlib"
depends="zathura"
-makedepends="zathura-dev poppler-dev libspectre-dev"
-source="https://pwmt.org/projects/zathura-ps/download/zathura-ps-$pkgver.tar.gz"
+makedepends="zathura-dev poppler-dev libspectre-dev meson ninja"
+source="https://pwmt.org/projects/zathura-ps/download/zathura-ps-$pkgver.tar.xz"
options="!check"
builddir="$srcdir/$pkgname-$pkgver"
build() {
- make -C "$builddir"
+ cd "$builddir"
+ meson build --prefix=/usr
+ ninja -C build
}
package() {
- make PREFIX=/usr DESTDIR="$pkgdir" \
- -C "$builddir" install
+ cd "$builddir"
+ DESTDIR="$pkgdir" ninja -C build install
}
-sha512sums="043898fdca56bee28a8e2af61d3216af25e222c0a137737e599881bb21e805dd8a609ff2901a50763bdbb34bf2e3fca2afaf1a59b715f3ba6aa067971c99c258 zathura-ps-0.2.5.tar.gz"
+sha512sums="6631f9b1c951b6f91f2a5217c3de47176205102206f15b596fb21285dae8d01fd759cfaca1b8a23bf47166dfbc3f8cf6061ce5a4d7a1c3a2b671a3beef5a07bb zathura-ps-0.2.6.tar.xz"