aboutsummaryrefslogtreecommitdiffstats
path: root/community/zutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/zutils/APKBUILD')
-rw-r--r--community/zutils/APKBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/community/zutils/APKBUILD b/community/zutils/APKBUILD
index eb50fdb536d..5936ac85cd6 100644
--- a/community/zutils/APKBUILD
+++ b/community/zutils/APKBUILD
@@ -1,34 +1,35 @@
# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=zutils
-pkgver=1.7
+pkgver=1.13
pkgrel=0
pkgdesc="A collection of utilities able to process any combination of compressed and uncompressed files transparently"
-url="http://www.nongnu.org/zutils/zutils.html"
+url="https://www.nongnu.org/zutils/zutils.html"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
subpackages="$pkgname-doc"
-checkdepends="bzip2"
-source="https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.lz
- CVE-2018-1000637.patch
+checkdepends="bzip2 gzip grep"
+source="https://download.savannah.gnu.org/releases/zutils/zutils-$pkgver.tar.lz
+ noconflict.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
- ./configure --prefix=/usr
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ CXXFLAGS="$CXXFLAGS"
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="eaf49d9aefb21460635eb6d0f1ae49ddc51b5a4e5d6d0943637194351ef910471203908d6bfe93ad37ca62ceacebe5b208d12b4bb8dda68cd9dbcdb7c7f848e1 zutils-1.7.tar.lz
-de30e5458b294175cfb3ab9c2031e80c7a4269cf7cf5968e08690ea363bc057a4b052d3a6979d577e8e2182a0a74bc02997c1ba074baa97223b23057b73d6799 CVE-2018-1000637.patch"
+sha512sums="
+d0decf5890b091845b8f1b6fa2541961e54be888ae0c6e54512b6296c9a3bcb2ff80d2b9a2f2644c4aa51cc8a4e0d031138a027d6a76b779fb5cd5c45aa24f14 zutils-1.13.tar.lz
+646b7a9e9f9aa445d3e4c75457a4a57b4481ad9314a2b29ae7b82d7d90a50204ad8e0b0dc0e2bf47addd39d599bf681919e405e3159fe8420f3b0bb95c6e3517 noconflict.patch
+"