aboutsummaryrefslogtreecommitdiffstats
path: root/community/zzz/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/zzz/APKBUILD')
-rw-r--r--community/zzz/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/zzz/APKBUILD b/community/zzz/APKBUILD
new file mode 100644
index 00000000000..44bec4a5859
--- /dev/null
+++ b/community/zzz/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=zzz
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="Suspend or hibernate your computer"
+url="https://github.com/jirutka/zzz"
+arch="all"
+license="MIT"
+makedepends="asciidoctor"
+subpackages="$pkgname-doc"
+source="https://github.com/jirutka/zzz/archive/v$pkgver/zzz-$pkgver.tar.gz"
+options="!check" # no tests provided
+
+build() {
+ make CFLAGS="$CFLAGS -DZZZ_LOCK_FILE='\"/run/zzz.lock\"'"
+}
+
+package() {
+ make install DESTDIR="$pkgdir" prefix=/usr
+}
+
+sha512sums="
+34a7eda018072b0920405d29763610a019367a6c9aef563524d52719517a135fd09a0feef4bcf054ed460e5040b44ec80c8f72c8a6efb4a9735c2edccb862d70 zzz-0.1.1.tar.gz
+"