aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libcdio/APKBUILD52
-rw-r--r--community/libcdio/disable-broken-test.patch34
2 files changed, 86 insertions, 0 deletions
diff --git a/community/libcdio/APKBUILD b/community/libcdio/APKBUILD
new file mode 100644
index 00000000000..b84e28c1dae
--- /dev/null
+++ b/community/libcdio/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Carlo Landmeter
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libcdio
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="GNU Compact Disc Input and Control Library"
+url="https://www.gnu.org/software/libcdio/"
+arch="all"
+license="GPL-3.0-or-later"
+checkdepends="bash"
+makedepends="libcddb-dev ncurses-dev linux-headers"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools ${pkgname}++:_cpp"
+source="https://ftp.gnu.org/gnu/libcdio/libcdio-$pkgver.tar.bz2
+ disable-broken-test.patch"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-vcd-info \
+ --disable-static \
+ --disable-rpath \
+ --disable-cpp-progs
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+tools() {
+ pkgdesc="libcdio example tools"
+ install -d "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+_cpp() {
+ pkgdesc="libcdio bindings for C++"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*++.* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="c290821da55fd9ae366670a58857aa6efcebc9f25b7caea063cf12f9cbda84fe770c5f59f972227fda50517ca58c5f39c0137daa0f93179e3daa45303d8b610f libcdio-2.1.0.tar.bz2
+be0149128bb2fa131f514bcff848279d826340a99a05b958e104f4640bda1a89d6146b0ec348783f4bbd8a3c313c41297152f75ee04f492f08b337bd79dd9c3e disable-broken-test.patch"
diff --git a/community/libcdio/disable-broken-test.patch b/community/libcdio/disable-broken-test.patch
new file mode 100644
index 00000000000..223445df3fe
--- /dev/null
+++ b/community/libcdio/disable-broken-test.patch
@@ -0,0 +1,34 @@
+--- libcdio-0.94/test/driver/realpath.c.old 2015-05-08 06:40:54.000000000 -0500
++++ libcdio-0.94/test/driver/realpath.c 2017-10-07 02:03:01.832979859 -0500
+@@ -155,6 +155,7 @@
+ check_rc(unlink(psz_symlink_file), "unlink", psz_symlink_file);
+ }
+
++#if 0 /* This test requires undefined behaviour in realpath(3). */
+ /* Make sure we handle a cyclic symbolic name, e.g. xx -> xx */
+ cdio_realpath(psz_symlink_file, symlink_file);
+ rc = check_rc(symlink(psz_symlink_file, psz_symlink_file),
+@@ -168,6 +169,7 @@
+ }
+ check_rc(unlink(psz_symlink_file), "unlink", psz_symlink_file);
+ }
++#endif
+
+ }
+
+--- libcdio-0.94/test/malformed.right.old 2015-05-07 23:25:02.000000000 -0500
++++ libcdio-0.94/test/malformed.right 2017-10-07 02:08:17.898937537 -0500
+@@ -1,3 +1,3 @@
+-Error getting above directory information
+ __________________________________
++Error getting above directory information
+ ISO-9660 Information
+--- libcdio-0.94/test/malformed2.right.old 2015-05-08 05:54:32.000000000 -0500
++++ libcdio-0.94/test/malformed2.right 2017-10-07 02:09:46.362072631 -0500
+@@ -1,5 +1,5 @@
+-Error getting above directory information
+ __________________________________
++Error getting above directory information
+ ISO-9660 Information
+ 2048 /a
+ 0 /b.txt